Support » Fixing WordPress » Problem: url for my site directs to a partial page with dead links

  • jennings

    (@jennings)


    I’m running a WordPress blog hosted by a Linode server running Debian 9. When I updated my system software, it broke the link to the blog. I have reinstalled everything (lamp stack, WordPress, etc.) and tested that apache / php are connected properly to my url. But the url points to a page that is clearly related to the blog without being the blog itself; I’ve copied the page below. All the links are dead.

    Advice? Thanks in advance!

    Menu
    Home
    About
    On the Loose

    Wherever My Feet and Mind Take Me

    Skip to content
    Last Day in Oaxaca: Of Mitla, Markets, and Rugs

    Posted on March 24, 2019May 27, 2020 by jennings

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Bruno Souza

    (@brunobsouza)

    Hi,
    I suggest taking a look if your permalink option is correct.
    On your WordPress dashboard go to > Settings > Permalinks
    Cheers!

    Thread Starter jennings

    (@jennings)

    The problem is that I can no longer reach my WordPress dashboard through my url and I know of no other way of getting there…any ideas?

    Thanks very much in advance.

    Bruno Souza

    (@brunobsouza)

    I never used Linode server but in some servers you can login to your WP installation from their control panel.
    Maybe try to open a support chat with Linode to ask if they have this feature?

    Thread Starter jennings

    (@jennings)

    Thanks…I’ll try it!

    Thread Starter jennings

    (@jennings)

    I’m waiting for an answer form Linode, but in the meantime I’ve discovered the note below on a page detailing how to install WordPress. The problem is that I have no idea how to access the VirtualHosts codeblock on my WordPress site. Any ideas? I can get into my server using terminal, and know how to use an editor, but can’f find this file.

    Note
    If using permalinks to set your posts’ URLs, Apache will need to be updated to allow individual sites to update the .htaccess file. To permit this, add the following to you WordPress website’s VirtualHosts code block:

    1
    2
    3
    4
    5
    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>
    You will now be able to login to your new WordPress-powered website. You can continue the configuration of your WordPress site from the web-based interface.

    Congratulations! You have now successfully installed WordPress.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem: url for my site directs to a partial page with dead links’ is closed to new replies.