Support » Fixing WordPress » problem uploading pictures

  • Resolved mudlerman


    I installed WordPress on a dedicated virtual server (at On that server I created a new MySQL database. Then updated the config file with the server info. Uploaded all my WordPress files. Then installed WordPress. I got the message that WordPress was successfully installed. I see my blog and can get to the dashboard. I can even write a post. Everything seems to be working but I cannot upload pictures.

    This is the error I got:

    Unable to create directory /var/www/vhosts/ Is its parent directory writable by the server?

    How should I trouble shoot this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator t-p


    -make sure images are not blocked by hotlink protection, contact your webserver.

    – check path in Admin => Settings => Media

    – make sure wp-content/upload folder is writable (try 766, 767, or 777 permission).

    I also use GoDaddy and ever since I upgraded to the 3.1 version of WordPress, my website, shows me white pages, the Visual tab is blank or it shows the html code instead of the images and words.

    I’ve tried changing the theme. On the web, it looks great but building it is a pain. What to do, besided uninstalling and rebuilding . . . I have 108 pages on my site.!?!?!?!?

    Moderator t-p



    -deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually (one-by-one) to find the culprit.

    If you don’t have access to your admin area, try deactivating them manually via FTP or phpMyAdmin.

    -switching to the default theme (“twentyten”) for a moment by renaming your current theme’s folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

    THANK YOU, THANK YOU! My problem is solved! I deactivated my plugins one at a time and when I deactivated “WordPress PDF by Digitalist,” the Visual Tab started working as it should be.

    Thanks for your help!!

    Moderator t-p


    You are welcome. 🙂

    Please mark thread as “resolved” using the dropdown in the right panel so that:
    – others with similar problem can see it as “resolved” and will read this thread for help if they have similar problem.
    -volunteers providing help see it as “resolved” and will not waste time reading this post.


    mudlerman began this thread, I was just expanding on the subject. I can’t find anywhere on the right panel that gives me the option to “resolve” this issue. Sorry!

    I’m still getting the error message. I did the following

    -make sure images are not blocked by hotlink protection, contact your webserver.
    I checked with my provider and nothing is blocked.
    – check path in Admin => Settings => Media
    It is set to wp_content/uploads, the actual location is which didn’t work
    – make sure wp-content/upload folder is writable (try 766, 767, or 777 permission).
    I’m not sure how to do this.

    by the way I’m on a Mac

    I was facing same issue but when I deactivate wp smush it plugin issue was resolved so if you are using that then try disabling that and check!


    I got this information from GoDaddy. It fixed the problem.

    I understand that you are experiencing issues with uploads through WordPress. The most common issues that cause this on Virtual Dedicated Servers is Permissions and PHP Mode. With wordpress you need to ensure that your Uploads folder, typically under the wp-content folder, is set with write permissions. You can do this through the Plesk File Manager by clicking on the letters to the right of the folder name that look like “rwxr_xr_x”. If they had write permissions they would like like “rwxrwxrwx”.

    The other common issue is the PHP mode. PHP will be set as an Apache module by default. This will cause any files uploaded by PHP, and wordpress as a PHP application, to be generated with the user and group root. As you are using plesk files created with the user and group root cannot be modified, moved, or deleted by your plesk user. To work around this you can set PHP to run as a FastCGI module. This will then make any files generated by PHP and your WordPress application be created as your Plesk user so you can interact with them freely. You can change this by logging into Plesk, selecting domains, selecting control panel to the right of your domain, selecting Websites & Domains, scroll to the bottom of your screen and click on the domain name. In this screen you will see a line that states “PHP Support (run as” with the module type in a drop down menu next to it. You can change it to FastCGI here and then select okay at the bottom.

    NO, NO, NO

    NEVER SET PERMISSIONS LIKE “rwxrwxrwx” (777)!!!

    In most of the cases this means that everyone has permission to upload anything (like a php) and execute it to hack everything in your website. We are talking about giving complete file control to anyone.

    There are exceptions (depends on the webhost’s server settings) but you have to really, REALLY be sure before doing this. This solution cannot be safe for everyone.



    Forum Moderator

    “Never” is an awfully strong word – especially since the poster in question was following advice from his hosting providers.

    some times..the gd library not installed on godaddy dedicated server.
    install it via easy apache..
    if you are experiencing the same issue..just check gd library….

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘problem uploading pictures’ is closed to new replies.