Support » Fixing WordPress » problem uploading header image

  • BiggoCharley


    I have found a lot of incidences of this problem going back as far a six years. I have read every post I could find and tried all of the proposed solutions that seemed to relate to my problem.
    When I try to change the header image I get the following error message:
    The uploaded file could not be moved to /home/httpd/vhosts/
    I have tried changing permissions to all different levels. The most liberal of which is 777 and which should allow uploading by the group. I have made sure that I am the owner of the image file. I am able to upload manually to wp-content/uploads with FTP so I don’t think that this is a server issue. I’m about ready to give up and reinstall WP unless someone has a better idea. (which I hope is the case).

Viewing 1 replies (of 1 total)


    WordPress uses the move_uploaded_file() function. In this case it is failing at this portion.

    Several error types can happen. Here’s the list.

    Under the wp_handle_upload() function, you can use the print_r($_FILES) function to see the error. Place it after the move_uploaded_file() function is called and call the die() function next.


    Alternatively, you can install a 2nd WordPress to see whether it has the same issue.

Viewing 1 replies (of 1 total)
  • The topic ‘problem uploading header image’ is closed to new replies.