The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Problem upgrading WordPress (9 posts)

  1. tdn7
    Posted 4 years ago #

    I upgraded 2 WP blogs to 3.2.1 (from 2.3), following the manual instructions from here:

    The first blog upgrade worked fine.

    However, when I try to upgrade the second blog and go to:
    ... I simply get a blank page.

    If I try going to:

    ... then the URL changes to:
    ... and the page is again blank.

    Any ideas?


    P.S. I did search for a similar problem, and found this thread:
    ... but the recommendation did not solve anything for me, and the thread has been closed.

  2. govpatel
    Posted 4 years ago #

    Did you deactivate plugins and change default theme

  3. tdn7
    Posted 4 years ago #

    Thanks for the response, govpatel.

    Did you deactivate plugins and change default theme

    No, I did not. The plugins and theme are exactly the same as for the first blog (which worked fine). For the theme, I had my own customized theme, so I figured that there was no other theme(s) in the upgrade that could overwrite any of my theme files.

    Anyways, I cannot get into WordPress to deactivate them now...

  4. govpatel
    Posted 4 years ago #

    Is there anyway you can get server error from your host account see which file is causing the problem as may be files got corrupted while upgrading.

    If you can not get error from server try
    WordPress Site Files

    If you want to check what files are causing the problem then you can

    First check wp-config.php if you do not have any blank space before


    if there is none then try and add this code in next line

    error_reporting(E_ALL); ini_set('display_errors', 1);

    In addition, add the following code above
    /* That’s all, stop editing! Happy blogging. */ :

    define( 'WP_DEBUG', true);

    See what error you get.

    and replace the files that are giving error from fresh WordPress download.

  5. tdn7
    Posted 4 years ago #

    Thanks, I'll try that when I get back later tonight.

  6. tdn7
    Posted 4 years ago #

    Govpatel, first of all, THANK YOU, THANK YOU for your assistance. Greatly appreciated!

    No blank spaces before:

    // ** MySQL settings ** //

    Made the edits you suggested to the wp-config.php file. These are the errors I got:

    Notice: Constant ABSPATH already defined in /home2/XXXXXXX/public_html/XXXXXXX.com/wp-config.php on line 23

    Parse error: syntax error, unexpected $end in /home2/XXXXXXX/public_html/XXXXXXX.com/wp-admin/includes/comment.php on line 129

    I checked line 129 in that file, and the comment.php file is cut off there. I downloaded the comment.php file from my other blog (the one that's working), and there is definitely more code after that line 129.

    [So presumably the comment.php file got corrupted while I was FTPing it???]

    I copied the working comment.php file (from the first blog) to the second blog, and I was then able to update the WordPress database.

    However, I was still getting the first (error?) message:

    Notice: Constant ABSPATH already defined in /home2/XXXXXXX/public_html/XXXXXXX.com/wp-config.php on line 23

    Next, I again removed the error_reporting and WP_DEBUG lines from the code in the wp-config.php file (those lines govpatel gave 2 postings above), so now the above message is no longer showing up.

    I have no idea if there is still an error there or not, regarding the "Constant ABSPATH already defined" message... but so far, everything seems to be working fine.

    Once again, THANK YOU for your help!! :-)

    I would have had NO CLUE where to being looking for this error, so that debug code for the wp-config.php file is hugely appreciated!

  7. govpatel
    Posted 4 years ago #

    You are welcome so you have your wordpress working now you need take the code I gave you out of wp-config.php file.

  8. tdn7
    Posted 4 years ago #

    Yes, have done. Thanks again, govpatel!

  9. burningroom16
    Posted 4 years ago #

    I have the same problem!!! got it now thanks..
    [link removed]

Topic Closed

This topic has been closed to new replies.

About this Topic