Support » Installing WordPress » Problem upgrading to WP 2.6.1: phpinfo() disabled in functions.php

  • I was upgrading wordpress on my friend’s website. When I went to the admin panel, it said I had to update the database, so I clicked the button but it keeps on saying “
    Warning: phpinfo() has been disabled for security reasons in /home/ocnj/public_html/wp-includes/functions.php on line 2223″
    I tried playing with the code in functions.php on line 2223 with no luck, and the database can’t upgrade. The rest of the website displays perfectly, but I can’t access the admin panel.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Warning: phpinfo() has been disabled for security reasons

    Wow. I’m speechless.

    Tell your friend that his webhost sucks rocks and he needs to switch to a new one.

    Well, I have also disabled phpinfo through a rule in my php.ini file. I don’t want people poking through my files if I can help it.

    Do I have to take phpinfo out of that rule (I disable a few other things aswell with the same rule), so that the 2.6.1 upgrade will work? It sounds like it.. I hadn’t tried upgrading yet, I always come looking here before I do “just in case”.

    Do I have to take phpinfo out of that rule (I disable a few other things aswell with the same rule), so that the 2.6.1 upgrade will work?

    Yes.

    The phpinfo function is not one that people normally disable for “security”. Web applications need to be able to determine the server configuration and behave accordingly.

    In this case, phpinfo is being used to see if mod_rewrite is loaded.

    I’m having the VERY same problem…

    so how EXACTLY should I fix it? Please help! I’m not extremely savvy, but I do understand and take instructions VERY well! 🙂

    it’s resolved

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem upgrading to WP 2.6.1: phpinfo() disabled in functions.php’ is closed to new replies.