Support » Fixing WordPress » Problem upgrading to 3.7

  • I upgraded from 3.6 to 3.7 and now I cannot access my site. I get this message:Fatal error: Call to undefined function wp_get_current_user() in /home/eichste/tackshots.com/wp-includes/user.php on line 215
    After I got this message, I foolishly tried to update again and over-wrote my old (backup) folders. Ouch! I do have current database backups from before the update, however.
    My site is – tackshots.com

    What can I do?

    Thanks in advance for your kind help,

    Jim

Viewing 15 replies - 1 through 15 (of 29 total)
  • hey i go to your site and got it normally again, how you fix it? i have same error too… 🙁

    Same problem here…..
    on past a hour i upgraded wp 3.6 to 3.7 and get same error…
    Fatal error: Call to undefined
    function wp_get_current_user()
    in /home/u734420510/
    public_html/wp-includes/
    user.php on line 215
    ….
    Please give solution to this problem. ASAP…
    …..
    My Site : http://MyapkBox.com
    …..
    Even i unable to visit my site!!!!!
    PLEASE Give Solution ASAP : (

    It’s not fixed. Visitors see the site ok (with a few glitches) but when I attempt to log-in at wp-admin, I get the error message that I reported. I should note that I used the automatic update process and did not de-activate plugins. I am afraid to attempt a manual upgrade until I can get some advice.

    If you have the same problems, perhaps others are, too, and we’ll get a quick resolution.

    Thanks,

    Jim

    I had the same issue with a plugin I am developing. It could be your theme, a plugin that is initialized improperly, or a function that is calling core functions of WordPress too early during execution.

    If you have access to your files on your server (cPanel’s FileManager, FTP, or equivalent) you can disable your plugins by renaming the /wp-content/plugins/ folder to something like /wp-content/plugins_bak/ and then see if you can at least access your wp-admin section. If so, then that means the issue is with a plugin you are using. You can rename the plugins folder back to the original plugins then you will have to manually rename each plugin’s folder individually and check the admin section after you change each one to see if you gain access.

    I would start with plugins that are not as popular and maybe outdated first, then work your way from there.

    Hope you get this sorted out.

    Same error for me, too 🙁 4 of my sites worked perfectly, but the 5th and final one came up with this –

    Call to undefined function wp_get_current_user() in /home/.../public_html/.../wordpress/wp-includes/user.php on line 215

    A quick google and I ended up here – looks like it’s not such a common error ? Any ideas on the best way to fix ?

    EDIT
    Thanks for your detailed advice, sforsberg – I use about 60 active plugins, so it might take me a while, but I’ll get started !

    I was able to quickly solve my problems by reuploading only the old includes directory. For now the site works again…

    Yah…
    Thanks “Sberg”
    Renamed Dictionary Plagins and till now i can acsess my site….
    not all right on my site..
    now i going find which plugin generating problem!!!!!
    …….
    My Site: http://MyapkBox.Com
    …….
    Thanks a Lot.. For Quick Replay. 🙂

    I’ve upgraded several blogs to 3.7 After upgrading the yellow statusbar ‘WordPress 3.7 available!’ stays on top of the admin menu.

    What’s wrong?

    Well, that was quick, and bad news for me – renaming the PLUGINS file didn’t work, so it looks like it must be my theme, right ?

    Both my site and the admin are completely down – I get a single line error message.

    Thanks, udobnoposvetu – I will give that a try next.

    margje – sounds like a different problem – maybe start your own topic thread ?

    Hello,

    I was trying to install WordPress 3.7, and during and after the installation I’ve got this message:

    Parse error: syntax error, unexpected $end in /home/thequali/public_html/wp-admin/includes/update.php on line 341

    What can I do to be able to enter again in my blog with wp-admin and fix this? Please I need detailed explanations, I am a very beginner user.

    Many thanks in advance,
    Alberto

    eichste: you faced the problem during the upgrade or post upgrade?
    wp_get_current_user() is a valid function AFAIK, i use it in my functions.php and things are fine with 3.7.

    udobnoposvetu: you are creating more trouble that way IMO.. pluggable.php (which contains wp_get_current_user) itself has 19 file diffs compared to 3.6.1, more than 164 files have changed, 3 new JS files of zxcvbn (the new password security thingie) and certificates and date.php are newly introduced..

    thanks sforsberg, i rename it
    yep, i can access my web again, seem troublemaker from the plugin (i still search what plugin that make it trouble) compatibility issues.

    J. Alberto Gonzalez: looks like a theme problem. what theme do you use?

    OK – I’ve found a fix for the problem in the original post –

    Call to undefined function wp_get_current_user() in /home/.../public_html/.../wordpress/wp-includes/user.php on line 215

    that doesn’t require the uploading of the entire INCLUDES directory.

    You need to add this line to the top of your CAPABILITIES.PHP file –

    require_once ('pluggable.php');

    so it looks like this –

    <?php
    
    require_once ('pluggable.php');
    /**
     * WordPress Roles and Capabilities.

    Thanks to this post from 2010 and this more recent post with screenshots. For reference – there’s also mention here to a specific plugin giving a similar error, which might be useful to someone.

    Obviously editing core WP files like this is not recommended as a permanent fix, as it may cause other issues, and you’ll need to apply the fix every time you upgrade WP. But at least my site is back online again, till a more elegant solution is worked out by the coders out there.

    Yup same problem with Call to undefined function wp_get_current_user() in wp-includes/user.php on line 215

    I followed the plugins method using ftp and isolated the problem to be, almost typically if you follow the other threads on the forum….NEXTGEN GALLERY.

    I am running version 2.0, their major update as I have not dared touch it since then, having lost everything for 24 hours.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Problem upgrading to 3.7’ is closed to new replies.