Support » Fixing WordPress » Problem updating/uploading pictures

  • Hello
    I have a big problem with my website.
    Someone in the place that I work installed a program for a book database, and after that, WordPress started to fail.

    The password to Cpanel was changed after the setup of that program. I don’t know if maybe it’s that the main problem.

    First, the web didn’t load (white screen). I’ve already fixed that, deactivating one plugin.

    But now I have a big problem.

    When I update others plugins, all of them gave me this message
    Update Failed: The package could not be installed. PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘/tmp/ocean-extra.1.6.2-IcsRUO.tmp’

    When I try to update wordpress, I have this message
    Download failed.: The checksum of the file () does not match the expected checksum value (862fd83d0476178410e9edca34775e44).

    Installation Failed

    And when I upload images, I have this:
    Missing a temporary folder.

    With the last problem, I tried the fix of changing wp-config.php and adding a php.ini to the main web.

    I asked to the hosting, and they tried but they couldn’t do anything. So i’m starting to lost all hope with this. I have 3 problems together.

    I used a backup of the site, but It didn’t work.

    The web is online, I can add posts, but no images and no updates can be done.

    Any suggestions?

    Thanks!!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • I doubt it was the password of the CPanel causing this problem…

    Once CPanel is done setting things up it usually is ‘out of the way’ but you can break things again via the CPanel. And you can fix things from CPanel if you can find the problems.

    I don’t know much about Litespeed server but I suspect it’s a file system permissions problem and that might be centered around that temp directory which is where I’d start.

    This article might point you to the right solutions.

    https://wordpress.org/support/article/changing-file-permissions/

    Remember also, that Xnix based servers have file permissions and Ownership permissions within those permissions.

    One ‘quick and dirty solution’ would be to temporarily set all file permissions to 777 and test then go back and set the permissions and ownership properly…

    This article will go more in-depth about tightening permissions and prevention of future problems.

    https://wordpress.org/support/article/hardening-wordpress/

    I recommend you follow it carefully when you’ve solved your problems.

    Let us know if you need anything else.

    Thanks!!
    I will try today, and I tell you what happens with this

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.