WordPress.org

Support

Support » How-To and Troubleshooting » Problem Updating to 3.7

Problem Updating to 3.7

  • Ok so when I try to use automatic update it hangs on “Downloading Update”, I use 1&1 hosting and found that adding the below

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    to your root .htaccess should sort the issue however whenever I do this everything on my site then just displays as php code. I then tried manually updating following the steps provided by WP then I begin getting lots of fatal errors even though I followed word for word.

    If anyone could provide assistance it would be greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • SRD75
    Participant

    @srd75

    Have you tried downloading the zip file and uploading the files over FTP?

    I have indeed, I use Filezilla, I deleted the WP-Admin and WP-Includes files as specified, copied them via FTP, copied the folders inside of WP-content to make sure I keep my themes and plug ins intact, however I did not got any overwrite warnings so copied them, copied the loose files into the root directory. But this led to either the site not working at all, fatal errors or the entire site displaying as php code.

    Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    however whenever I do this everything on my site then just displays as php code.

    I think you’ll need to give your hosting a call. That should never happen and the PHP code should be interpreted. It may be a quick fix but your hosting company should be able to sort that out for you.

    Ok will try give them a call, from what I understand 1&1 uses Php5 while WordPress still uses 4 correct?

    Andrew Nevins
    Forum moderator

    @anevins

    WordPress requires PHP 5.2.4 or greater http://wordpress.org/about/requirements/

    So why does it run ok now but then struggle to update? I believe 1&1 does allow for that version of PHP however I will enquire tomorrow 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem Updating to 3.7’ is closed to new replies.