Support » Plugin: All In One WP Security & Firewall » Problem update from 4.4.2 to 4.4.3

  • Resolved Patrice

    (@patricevigier)


    Hello,
    After I upgraded fro 4.4.2 to 4.4.3 I had a white page, impossible to see the site.

    I turned on the WP debug and here is the error.
    “Can’t use function return value in write context in wp-security-file-scan.php on line 176”

    PHP version 5.4
    WP 4.9.8

    What can I do?
    Sincerely
    Patrice

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, can you carry out the following test. Disable and delete the plugin. Then install a fresh new copy. But before you do this, make sure you create a backup of your site.

    Let me know if the above helps.

    Thank you

    Thread Starter Patrice

    (@patricevigier)

    Hello,
    Thank you for your answer.
    I did but not from the admin because I do not have access (white page) but I deleted the folder in the plugin directory then I tried to instal the new version from the admin but I could not. I got the same message but this time from the WP admin that refused to install it.

    As for now I reinstalled the previous version.

    Sincerely
    Patrice

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    Go to Tools -> Site Health -> Status. Check to make sure there are no major issues.

    Kind regards

    Thread Starter Patrice

    (@patricevigier)

    I do not have “Site Health” in tools

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Oh, yes sorry that is correct. WP 4.9.8 does not have site health feature added. Have you tried updating your WordPress version to the latest or at least WP 5.3.2?

    Thread Starter Patrice

    (@patricevigier)

    I’m always worry to upgrade…. but since the site is not live I will see if my theme is compatible, and if yes I will.

    Thread Starter Patrice

    (@patricevigier)

    I cannot update, I my PHP version is too low.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, if your PHP version is too low then I suggest that you upgrade the PHP. Looking at the original question above, I can see that you are currently using PHP 5.4 which is very old. I should have spotted this early. Please check the following link https://www.php.net/supported-versions.php.

    Sorry for not noticing this earlier.

    Regards

    Thread Starter Patrice

    (@patricevigier)

    Hello again,
    I know it is a old version but at this time I cannot upgrade PHP.
    I suggest you mention in your plugin what minimum PHP is required.
    Thank you for your help.
    Patrice

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Thank you for sharing that information.

    Kind regards

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problem update from 4.4.2 to 4.4.3’ is closed to new replies.