Support » Plugin: Loco Translate » Problem translate Gabfire Linepress 2.8 theme

  • Resolved yard

    (@yard)


    Hello,

    I have trouble with Gabfire theme Linepress ver. 2.8. translation. Loco Translate plugin notify me some errors in theme bundle:

    1. missing us_US.mo file
    2. missing POT file

    In English and Turkish language Loco show´s me 135 strings, but after creation of Slovak language file, this show´s me only 43 strings

    Other strange issue is, that in first translation attempt I have “Read More” and “More” … strings in Slovak translation menu vissible, but after translation, this items was missing from Loco Translate and can´t edit it more.

    How can I correctly translate theme into Slovak ?

    please look here:
    http://screencast-o-matic.com/watch/cbViQ3QAQj
    http://screencast-o-matic.com/watch/cbViQUQAQ6

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Tim W

    (@timwhitlock)

    missing POT file

    Your first video that a template file is configured, although I have no way of knowing what it is. Presumably it only contains 43 strings, which is why you get 43 strings in your new Slovak file.

    My best guess is that template is wrong and that’s the crux of your problem.

    missing us_US.mo file

    This isn’t necessarily a problem. Most likely the theme author intended to use en_US.po as the template file instead of a POT file. Bad practice, but very common.

    The US English PO file seems to hold 135 strings. I suggest you configure the bundle to use this file as template instead. That’s assuming it is correct and up to date, which is not guaranteed. See documentation on the Advanced tab configuration: https://localise.biz/wordpress/plugin/manual/bundle-config

    I cannot account for why your second video shows the template missing, when it was present at the start of the first video. It would seem something has been modified, and you’ve not included information about what that is.

    As your theme is commercial, I cannot investigate it further. If you struggle with configuration please put the theme author in touch with me and I will help them ensure their theme is translatable with Loco Translate.

    Thread Starter yard

    (@yard)

    Hi dear Tim,

    thank you for quick reply. I was solve this by using us_US.po as template for new file created with POEDIT software. This sk_SK.po I was then placed into theme lang file. After this Loco Translate correctly show´s me number of strings.

    In my videos is POT file missing because I was created POT and deleted it for testing, but have no good result

    thank you for helping idea´s

    Hi guys,

    Thanks for reporting the issue Yard and yes, Poedit was the only way for you to add your language to theme at the moment.

    And thanks for your answer Tim. I believe the issue is caused due to multiple domains that we used. We will update the theme shortly so it works as expected with Loco Translate as well.

    Plugin Author Tim W

    (@timwhitlock)

    Good news all round.

    @gabfire Loco can support multiple domains across the localisation process. If you’re interested in shipping a loco.xml file with your theme, I can help you with that.

    Thanks both

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem translate Gabfire Linepress 2.8 theme’ is closed to new replies.