Support » Networking WordPress » Problem SSL with mixed content and ghost URL

  • Resolved Irene

    (@arlinaite)



    Hi,

    I migrate a few month ago to from http to https, a multisite with only two subsites. The main site is redirected to the Spanish version.
    https://example.com redirects to https://example.com/es
    And the other subsite is https://example.com/en

    Before I had a Inmotion shared hosting, Comodo free certificate from my host, and I get the green padlock easily.

    Now a changed server to Cloudways and I have Lets Encrypt certificate. First I setup certificate for non www, and I had the green padlock display without problem. Then I add to certificate, also domain with www, and since then green padlock changed to gray https.

    I have an error message for insecure content, detected with chrome console:
    Mixed Content: The page at ‘https://example.com/es ‘ was loaded over HTTPS, but requested an insecure image ‘http://example.com/wp-content/uploads/sites/2/#’. This content should also be served over HTTPS.
    As you see, this URL belongs to the main site that is empty and I do not use, and this site is redirected. I had this error when I had the Comodo Certificate, but didn’t prevent the green padlock to display.

    I checked:
    -Certificates are ok.
    – Looked in the source code of the page, and the URL is not there.
    – Scan the site db with better search and replace and there is not such URL with http
    -I disable all the plugins and nothing changed. Also changed the theme of the main site.
    – I scanned the site with screamingfrog for insecure content, and did not find any error.
    – I load Really Simple SSL plugin and didn’t help
    Any clue how I could find a solution to this error?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • I also checked with a search, for hard coded url: http://surdelsur.com/wp-content/uploads/sites/2/, in the wp-content folder

    Irene

    (@arlinaite)

    I solved the issue.
    I found that the theme was trying to load an image background (which had never setup, inexistent, and wrong url) at the same time that a color background.
    I went to the customizer, look for the background and changed the color, saved, and this fixed the error.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problem SSL with mixed content and ghost URL’ is closed to new replies.