Support » Plugin: Contact Form 7 reCAPTCHA Extension » Problem solved! reCAPTCHA not showing

  • Problem solved!

    Just install the plugin “wp rollback”
    After installing go to plugin overview. you now find a rollback option below all the plugins. Rollback to previous version.
    After this go to integration on the contact form and paste your keys again like you did in the beginning.
    Open your contactform on the backend and save it again. Make sure you add the recaptha again 🙂
    No go to your frond-end and refresh your page.
    And your done!

    Wait for next update with the fix.

    No need te install any other plugins.

Viewing 15 replies - 1 through 15 (of 18 total)
  • This worked brilliantly, I will just leave it like that for now.

    Thanks…

    Thank you! But it does not work for me. Error: wrong key. I genarated a new pair but it did not help. I use WP 4.9.8.

    Dont know about version 4.9.8.

    I use the latest wordpress version.
    i used rollback on the contactform plugin to rollback from 5.1 to 5.0.5.
    After that it worked again.

    Maybe check you keys generated from https://www.google.com/recaptcha/ again.
    make sure you generate the key for the correct site offcourse.
    And maybe update your wordpress to the latest version.

    Hope this helps..

    I am using the current WP platform and I found this solution worked on chrome but not for firefox or safari. And now FF and Safari wont send the message.

    I tried different rollback stages, same issue.

    hapke

    (@hapke)

    Sorry but I get spam now. I use honeypot additionally. I deactivated it and updated CF today. But there is still no recaptcha shortcode available in FF browser.

    CDHeumann

    (@cdheumann)

    Read this:

    The latest version of the reCAPTCHA API is v3. Contact Form 7 5.1 and later uses this reCAPTCHA v3 API. reCAPTCHA v3 works in the background so users don’t need to read blurred text in an image or even tick the “I’m not a robot” checkbox.

    Note: API keys for reCAPTCHA v3 are different from those for v2; keys for v2 don’t work with the v3 API. You need to register your sites again to get new keys for v3.

    https://contactform7.com/recaptcha/

    Google’s reCAPTCHA v3 and Contact Form 5.1 are incompatible. Going back to Contact form 5.0.5 and reCAPTCHA v2 doesn’t work either.

    Try the quiz or a better form plugin like Formidable

    I beg to differ from the developpers: Recaptcha doesn’t work AT ALL in CF7 5.1 and higher. No matter if the recaptcha is v2 or v3, it doesn’t work at all. Why are they releasing updates when they don’t work?

    Thank you for the suggestion, @dexxonmartin. Reverting to 5.0.5 worked and did the thing.

    Ok. Latest WordPress (5.02), CF7 5.05, got ReCaptcha v2 to show up after repeated reinsalls.

    I re-registered my site with v3 of Recaptcha. Now, do I still need to add the [recaptcha] code to my contact form? I still don’t see the button for it. There used to be a button i could click to add recaptcha to the Contact Form. Really would like to get some clear direction on this. I’m getting a LOT of spam.

    it works thanks

    “Ok. Latest WordPress (5.02), CF7 5.05, got ReCaptcha v2 to show up after repeated reinsalls.”

    I can confirm that rolling back to 5.05 is also working for me.

    Thanks to @dexxonmartin for the suggestion.

    Nice Work! Rollback to 5.0.5 works

    🙂

    fingolfin1

    (@fingolfin1)

    We use the WP ROLLBACK plugin. Return to 5.0.5 version. Delete reCaptcha V3 from Google. Add new reCaptcha V2 keys in Google, enter those in the Contact Form 7 integration settings and everything is working great.
    I think that V3 has a lot of issues.

    For the spanish speakers here is the explanation in spanish.
    Instalar el plugin WP ROLLBACK y volver a la versión 5.0.5 del Contact Form 7.
    Borrar las claves reCaptcha V3 de Google y de la integración.
    Generar nuevas claves reCaptcha V2 en Google y agregarlas a la integración.
    Editar el o los formularios que tengamos agregando “reCaptcha”, guardar y listo.

    Yes. That works.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Problem solved! reCAPTCHA not showing’ is closed to new replies.