Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Problem sending message with reCAPTCHA

  • Resolved motix

    (@motix)


    Hi everyone

    I am having problem to send message through WPForms while using any reCAPTCHA, it seems like it does not seem to see that someone has clicked the field for reCAPTCHA and message “This field is required” appears, when I use the WPForms without reCAPTCHA it sends the message just fine.
    Also I tried to use Ninja forms with reCAPTCHA, the message is being sent but it does not reach the recipient.

    Is there anyone out here whom had same problem, please give me an advice because I do not know what to do, I do not want to have WPForms without reCAPTCHA as I am getting to much spam.

    Many Thanks

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Elkerton

    (@elkerton)

    Same issue here – form only works when reCAPTCHA is disabled. Otherwise selecting Submit button on completed form does nothing. Using v3, a reCAPTCHA checkbox appears in the editing window, but no sign of reCAPTCHA on preview or published form (including badge linking to Google TOS). Note: Updated to latest version of plugin today. Thank you.

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @motix,

    Thanks for reaching out!

    If you’re encountering this error, there could be that reCAPTCHA is getting loaded twice on the page — once by WPForms, and once by either your theme or another plugin, and this causes the error in the form.

    The possible next steps could be:

    1. You can try to track down what’s generating the other reCAPTCHA code and, if possible, turn it off.

    2. You can enable No-Conflict Mode in WPForm’s reCAPTCHA settings (under WPForms > Settings > reCAPTCHA tab

    Hi @elkerton,

    If the reCAPTCHA field or badge does not show up, and you’ve tried the steps shared above, there could be a conflict with another plugin or the site theme. To test for conflict, please see our detailed guide on testing for conflict.

    I hope this helps 🙂

    Elkerton

    (@elkerton)

    Might have a simpler solution. I went back to Google to check the settings on reCAPTCHA for my site. In the settings there was an option titled “Allow this key to work with AMP pages”. Checked the box and the form started working. I don’t recall seeing this option when I set up reCAPTCHA v3, but may have missed it.

    @motix If you have an AMP site, have you tried this?

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @elkerton,

    Thank you for taking the time to share your solution with us!

    Have a good one 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.