Support » Plugin: Postman SMTP Mailer/Email Log » problem sending mail with other users

  • Resolved oblamine

    (@oblamine)


    Hello,
    i have two users who are Administrator both they have right to send email notifications.
    when i send emails, from the first one, the plugin shows : email sent and i recieve the email. this is OK. (the email used to configure the postman smtp belongs the first user with authentification security level)
    from second one, plugin shows: email sent but i dont recieve any mail.
    i m using post smtp to configure smtp server.
    help please
    yours

    https://wordpress.org/plugins/postman-smtp/

Viewing 15 replies - 1 through 15 (of 26 total)
  • Hello,
    i chacked to checkbox of forcing users to use the sepecified email adress entered in the plugin but it doesn’t work.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    would you send me the two transcripts, one from an email you received and the other from an email you didn’t receive. You can find Transcripts in the Email Log.

    i sent you one file named del_prob.txt containing the two transcripts.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    250 2.6.0 Queued mail for delivery

    Ok. I see from the first transcript the email was sent from a custom domain to gmail and accepted by the server.

    550 5.7.1 Client does not have permissions to send as this sender

    The second was sent from a hotmail domain to a gmail domain and rejected by the server.

    Normally I tell people to fix this by adjusting their From header so that it is their own email address. However! The next version of Postman is smart enough to use a different address for MAIL-FROM and FROM to try and make your setup work as-is.

    Please download and install Postman SMTP v.1.6.13a and try your test again. You will be only the second person to try out this new feature.

    thank you very much for the quick answer. let me explain more the issue.
    in my site, all the mail notifications should be sent from just one email the one which belong the the costume domain.
    is there any way to force all users to use that email and not to use their own ones?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Yes, checking “Force this sender email address for all emails” will do just that.

    Btw, I just realized you have another problem. What plugin did you use to create the email message? Postman’s signature is not in the header, which means this plugin did not use wp_mail to send the message. Postman was bypassed entirely.

    i m using Email Users to generate emails.
    i checked that options but it didn’t work.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    I will do some tests later to see if Email Users is compatible with Postman. I’m not sure that it is.

    You’re not running Postman in ‘stealth mode’ are you?

    i dont know, how to check this?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    There’s an option on the Advanced tab for “Stealth Mode” – is it unchecked?

    it is not checked. should i check it?

    when i sent u the file it was checked! but now it is not

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Ah ok. That explains that mystery. Ok, so Email Users is compatible with Postman. But they are sending some unexpected headers that are causing your mail server to barf.

    Let me do some tests with their plugin please.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    If you haven’t, go ahead and install Postman SMTP v.1.6.13a. It may already resolve this problem with Email Users.

    oke, i will test it and keep you informed.
    is it stable release ?

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘problem sending mail with other users’ is closed to new replies.