Support » Plugin: Affiliates Manager » problem sending email login

  • Resolved evrard77

    (@evrard77)


    Hello,

    Your plugin has a problem, I noticed that the email of the identifiers sent by wordpress does not leave.

    Because quite simply the role is: affiliate and that’s all

    In order for him to receive the mail, he must also have the role of customer or subscriber.

    I did all the tests and it is the role that does not trigger the action of sending mail.

    How to correct the problem?

    It’s a shame your plugin is cool but this problem is complicated and I’m not the only one in this case.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Please carry out the following steps:

    1) Enable debug in the affiliates manager settings
    2) Reset the log file
    3) Do a test affiliate registration
    4) Go back to the settings and check the log file to see if the email was sent by the plugin

    Are you trying to register by logging in as an admin? If so no new WordPress user account will be created. You can either log out of wp-admin or open the registration page on a different browser to test it (where you are not logged into wp-admin).

    If the log file confirms that there was no error when WordPress sent the email, that means the email is getting lost somewhere else. Usually this type of issue occurs on servers where there are various restrictions in place (example: number of outgoing emails, type of email address used). You can install a SMTP plugin to bypass these restrictions and send email using a SMTP server.

    Let me know if the above helps you.

    Kind regards

    Yes check :

    [07/04/2019 2:11 PM] – SUCCESS : Mailchimp integration addon – Mailchimp signup is disabled in the settings.
    [07/04/2019 2:11 PM] – SUCCESS : Demande d’affiliation pour Alyra
    [07/04/2019 2:11 PM] – SUCCESS : Sending an email to “user”
    [07/04/2019 2:11 PM] – SUCCESS : Email was sent successfully by WordPress
    [07/04/2019 2:11 PM] – SUCCESS : Nouvelle inscription d’affilié
    [07/04/2019 2:11 PM] – SUCCESS : Sending an email to “my adress”
    [07/04/2019 2:11 PM] – SUCCESS : Email was sent successfully by WordPress

    it misses the sending of the user IDs…

    it’s only with your plugin because the emails work correctly on my site…

    • This reply was modified 6 months, 3 weeks ago by evrard77.
    • This reply was modified 6 months, 3 weeks ago by evrard77.

    however the emails work correctly from the purchases of our website no problem.

    As you can see in the logs, I don’t have the line to send the mail to the WP user.

    I think it’s a user role problem… NO

    After various tests I confirm that the different mails are sent through other plugins but not yours.

    Especially when I create a user manually as well as if customers make a purchase from the website.

    The way your plugin creates the user makes the mail not leave. I checked my mailboxes no spam problems!

    I need to receive this email:

    login: ***

    To set your password, go to the following address: URL

    However, registrations through your plugin do not trigger the sending of the email and what is really unfortunate is that you did not provide a “Password” field from your registration form. This is incredible!

    • This reply was modified 6 months, 3 weeks ago by evrard77.

    After several tests and trials I confirm that the problem is related to your plugin.

    When creating the user through your form this does not trigger any mail sending except those managed by your plugin no problem.

    On the other hand, if it is the password creation email sent by wordpress@mysite.fr this one is not triggered, I don’t understand why… because when creating a user manually the email is transmitted correctly. And the same for emails managed by other plugins have no problem…

    • This reply was modified 6 months, 3 weeks ago by evrard77.
    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, please read the following documentation. Let me know if this helps you.

    Thank you

    Plugin Author affmngr

    (@affmngr)

    @evrard77, Please use the contact form on our site to get in touch so we can investigate this issue: https://wpaffiliatemanager.com/contact/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘problem sending email login’ is closed to new replies.