Support » Plugin: Imsanity » Problem resizing anything over 3500px

  • This plugin is not resizing any images that are bigger than 3500px.

    I am getting the following error message: “Imsanity was unable to resize this image for the following reason: Image resize failed.. If you continue to see this error message, you may need to install missing server components. If you think you have discovered a bug, please report it on the Imsanity support forum: https://wordpress.org/support/plugin/imsanity”

    I carried out a painstaking test. First I kept the original dimensions of 4000 x 3000 but reduce the file size incrementally from 2MB to 500KB. The error message above still appeared.

    I then resized the original 2MB file incrementally from 4000px down to 3500px and then it uploaded the 3500 x 2625 image.

    Can you please tell me what changes are required to allow this plugin to resize images from 4000 x 3000 which tend to be the sizes I normally upload.

    thanks
    Terry

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Hi Terry,
    Your server very likely needs more memory to handle an image over 3500px. Stop reading if you don’t care about why 🙂

    While it might seem strange to run out of memory for a 2MB file, the underlying image library needs a certain amount of memory per pixel. Thus, the memory required for image scaling is dependent exclusively on the image dimensions, rather than the filesize, which is why you saw no difference in your tests with different file-sizes.

    For example, a 4000 x 3000 image will need at least 36M of memory, if not closer to 48M. Plus, PHP will need memory to store the scaled version too, which is going to be 9-12M more.

    i’m having the same problem. plugin refuses to resize large images. getting an error.
    1/1 >> ERROR: /nas/content/live/wynnlocations/wp-content/uploads/Cont.-Lobby-Exterior_7211.jpg (width or height exceeds limit `/nas/content/live/wynnlocations/wp-content/uploads/Cont.-Lobby-Exterior_7211.jpg’ @ error/cache.c/OpenPixelCache/3839)

    Plugin Author nosilver4u

    (@nosilver4u)

    @standoutsites — that isn’t the same error, your’s means the webhost has set a limit on the maximum dimensions that can be manipulated by PHP (imagick specifically). You’ll need to scale those down outside of WordPress, or ask your webhost if they will raise the limit for your site.

    clarification: in other words, there is nothing Imsanity can do with the image unless your webhost will raise the width/height limits.

    • This reply was modified 1 month, 3 weeks ago by nosilver4u.

    Hi nosilver4u,

    Thanks for your reply.

    Memory does not appear to be the problem. My server is running:
    upload_max_filesize = 256M
    post_max_size = 256M
    memory_limit = 512M

    I am running WP 5.3 and PHP 7.2.

    Any other ideas?

    Thanks
    Terry

    • This reply was modified 1 month, 3 weeks ago by terryally.
    Plugin Author nosilver4u

    (@nosilver4u)

    You’ll need to check your server error logs (or ask your webhost to do so), as it’s impossible to know what else might cause issues if it isn’t memory-related.
    You don’t need to have the upload limits so high though, only the memory_limit variable would impact the memory usage in PHP.

    I would, however, double-check two things:
    1. Go to Tools->Site Health->Info->Server and confirm that WordPress is seeing the same memory limit that you have configured.
    2. Check with your webhost to make sure they don’t have memory constraints outside of PHP. For example, if you’re on a server with 2GB of memory, and its serving too many sites, it might be running out of memory at the system level.

    terryally

    (@terryally)

    Hi,

    1. My server company checked the error logs and I carried out a number of tests at their requests to record errors for troubleshooting. The only error they turned up was the original error that I posted. They increased memory limits to the maximum allowable. they confirm that there re no memory constraints outside of PHP.

    They’ve concluded: “I believe that the best bet would be to pursue this further with the plugin developers, perhaps asking if there are any further system requirements or server configurations that you should be aware of.”

    2. I checked the Site Health and it shows the following:
    Server architecture Linux 2.6.32-754.24.3.el6.x86_64 x86_64
    Web server Apache/2.4.41 (Unix)
    PHP version 7.2.25 (Supports 64bit values)
    PHP SAPI cgi-fcgi
    PHP max input variables 7000
    PHP time limit 600
    PHP memory limit 512M
    Max input time 180
    Upload max filesize 256M
    PHP post max size 256M
    cURL version 7.19.7 NSS/3.27.1
    Is SUHOSIN installed? No
    Is the Imagick library available? No
    .htaccess rules Custom rules have been added to your .htaccess file.

    The error message the plugin is showing is: “Imsanity was unable to resize this image for the following reason: File is not an image.. If you continue to see this error message, you may need to install missing server components. If you think you have discovered a bug, please report it on the Imsanity support forum: https://wordpress.org/support/plugin/imsanity”

    Thanks

    Plugin Author nosilver4u

    (@nosilver4u)

    Imsanity simply uses the core WP_Image_Editor classes to manipulate images, nothing fancy is required beyond GD or Imagick being available (that I know of).

    Simply put, if the plugin can scale a smaller image, but runs into problems for larger ones, then memory constraints are the only thing that make sense.

    I tested a JPG image at 6000×4000 on my site with only PHP + GD, and Imsanity scaled it down properly (I had my settings at 2048×2048).

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.