Support » Plugin: AddToAny Share Buttons » Problem removing icon / service

  • Resolved hommealone


    On the settings page, under “Add/Remove Services” it says:

    Choose the services you want below. Click a chosen service again to remove.

    For some reason I cannot remove a service that I had previously added. I click it, double-click it, try to drag it back into the list, try to drag it off the page – nothing works. The icon seems to be stuck there, and I can’t remove it.

    What can I do?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author micropat


    This type of issue is usually caused by another plugin generating a JavaScript error or conflict in the admin panel.

    Have you tried temporarily disabling other plugins to pinpoint the culprit?



    I’ve tried deactivating plugins that contain any sort of drag-and-drop in the admin pages, but haven’t found any that have an effect. I can’t simply de-activate all of the plugins, there are too many and it is an active website.

    I tried deactivating and reactivating; no help.

    I deactivated this plugin, completely uninstalled the plugin via FTP by deleting the entire add-to-any folder from the plugins directory, and then re-installed. It still had all of my custom settings when I re-installed, with the unwanted icon still there.

    Any other suggestions?




    Forum Moderator

    There is no magic bullet in these situations. This is just the start of basic troubleshooting and is a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    Do you want to locate and, hopefully, fix the problem on your site? If “yes”, then please help us to help you and carry out the changes that plugin’s developer suggested.

    Your theme & plugin settings are saved in your database and should be retained for future use.



    Thanks for the reply. Wish I could help further with the troubleshooting, but can’t bill my client for it, so have instead fudged it by simply hiding that icon via CSS.

    Too bad there is not a true delete option for the plugin, which would also delete the database preferences, or an option to reset the preferences which would delete the prefs from the database. Maybe someday!

    Thanks for your help nonetheless, I appreciate it! And thanks, Micropat, for this plugin!

    Plugin Author micropat


    Good news: The Reset button you’re seeking is already in the plugin’s admin panel, right alongside the Save Changes button. It’s of course smaller, red, and requires confirmation. 🙂



    Excellent! Sorry I missed that. Again, thanks for this thoughtfully done plugin!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem removing icon / service’ is closed to new replies.