Support » Plugin: Polylang » Problem redirecting the main URL

  • Hello,
    I used polylang to translate my trilingual site. Everything works fine, the plugin is easy to use and complete.
    The main language of the site is French, when with Search Console I explore the site like Google, I get a redirection error. The message tells me that the primary URL redirects the site to the English version.
    According to the browsers it is actually the English version that is displayed from the main URL, once on the site even after selecting the French language, impossible to display the welcome in French.

    I disabled all the plugins replaced my theme by the default one and restarted Googlebot, the problem remains.
    Do you have any idea where the problem may come from?

    Thank you in advance.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Nothing ?

    Hi @agoost,

    I have the same problem on my site. I have set the default language to english but get redirected to my non default german site. This only happens on the homepage. The language switcher to the default language also doesnt work.

    It’s weird because when I use my safari browser, everything is fine. What browser are u using?

    Hi antongr,
    The problem appeared in Chrome and IE.
    Now it looks better, but the redirect problem persists when I’m doing a crawl like Google in “search console”.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem redirecting the main URL’ is closed to new replies.