Support » Plugin: Ultimate Member - User Profile & Membership Plugin » PROBLEM: Profile Photo upload via Mobile Phone

  • Resolved EugeneUK

    (@euguk007)


    Dear UM Developers,

    The Profile Photo upload on desktop pc works brilliant – Thank you!
    On my iPhone 6 it gets as far as uploading the image and then it just hangs like on the screen snapshot HERE

    The image is uploaded to the user’s UM folder in WP uploads.

    Please advise as soon as possible.
    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • I confirm that this is a REAL problem.
    Just made a clean install of the latest version on a fresh WP site – the same problem with photo upload from iPhone.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @euguk007,

    What version of the Ultimate member you have installed on your site?
    It looks like a conflict with your theme or one of your plugins.
    Please do a quick conflict test and see if this issue goes away.
    Here is the doc on how to do a conflict test if you are not sure how to do it.

    Regards.

    The latest test was on the new install of UM 2.0.49 with Twenty Sixteen 2.0 theme.
    Plugins installed:
    Classic Editor, Code Snippets, Disable Comments, Disable Gutenberg, Optimize Database after Deleting Revisions, Post Meta Inspector, Ultimate Member, User Role Editor Pro, WP Reset, WP SMTP, WP User Frontend, WP User Frontend Pro.
    Trying to upload an image from mobile (iPhone 6) is NOT working. As in the image before, it hangs after the green line of upload completes.
    As a test, I tried ProfileGrid plugin, which has a simpler uploader style, but with more features than yours, AND IT WORKS FINE ON ALL THEMES !!!

    • This reply was modified 4 months, 4 weeks ago by  EugeneUK.
    • This reply was modified 4 months, 4 weeks ago by  EugeneUK.

    Maybe you need to perfect your image upload function, make it an add-on and offer it as a paid extension ?
    I feel sorry for all the time spent on UM just to find out that some little important function fails you down the road !

    • This reply was modified 4 months, 4 weeks ago by  EugeneUK.

    It looks like I will have to reclaim my money from your 3-rd party add-on for Tabs to move away from the Ultimate (NOT) Member to something like ProfileGrid.

    1) Your design is outdated!
    2) Your crucial image upload function does NOT work on a mobile.
    3) Your response to your own script problems is NOT good enough in quality nor the speed.

    Alas, UM has to go!

    I apologise for my raging over this issue.
    Having found your https://ultimatememberdemo.com site I tested it on my phone and it works well. I will be restarting my UM project from scratch whilst checking ever step of the way. Sorry! And thank you!

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @euguk007,

    Can you please clarify what third party plugin for tabs are you referring to?
    We do not have this kind of extension.
    This issue is very likely caused by some conflicts with other plugins or settings on your hosting provider side.
    Please check this doc on how to troubleshoot Photo/image uploads

    Regards.

    WordPress 5.2.2
    Twenty Fifteen 2.5
    Ultimate Member 2.0.49 – the only plugin installed
    Testing on Local by Flywheel
    Apache
    PHP 7.1.4
    MySQL 5.6.34

    RESULT

    http://londonzoom.info/image2.png
    IT HANGS. NO CROPPING STAGE. THE IMAGE IS UPLOADED TO UM FOLDER.

    PLEASE tell me what else can I do!

    Web Server Configurations ---
    
    PHP Version:              			7.1.4
    MySQL Version:            			5.6.34
    Web Server Info:          			Apache/2.4.10 (Debian)
    
    --- PHP Configurations ---
    
    PHP Memory Limit:         			512M
    PHP Upload Max Size:      			1000M
    PHP Post Max Size:        			1000M
    PHP Upload Max Filesize:  			1000M
    PHP Time Limit:           			900
    PHP Max Input Vars:       			3000
    PHP Arg Separator:        			&
    PHP Allow URL File Open:  			Yes
    
    --- Web Server Extensions/Modules ---
    
    DISPLAY ERRORS:           			On (1)
    FSOCKOPEN:                			Your server supports fsockopen.
    cURL:                     			Your server supports cURL.
    SOAP Client:              			Your server has the SOAP Client enabled.
    SUHOSIN:                  			Your server does not have SUHOSIN installed.
    GD Library:               			PHP GD library is installed on your web server.
    Mail:                     			PHP mail function exist on your web server.
    Exif:				          PHP Exif library is installed on your web server.
    • This reply was modified 4 months, 3 weeks ago by  EugeneUK.
    • This reply was modified 4 months, 3 weeks ago by  EugeneUK.
    • This reply was modified 4 months, 3 weeks ago by  EugeneUK.

    Actually. The photo is assigned to the User. I can see it by cancelling the hanged up screen and revisiting the profile. I think the problem might be in your Cropping code. I will try to compare it with ProfileGrid and let you know.

    OK. I haven’t worked out as to Why the crop function doesn’t work on mobile in development environment of Local by Flywheel (remember that ProfileGrid works fine), but having cloned my site to live server it works absolutely well. I will now do some checks on XAMPP. Perhaps you need looking into this issue? Thanks!

    • This reply was modified 4 months, 3 weeks ago by  EugeneUK.

    I confirm that the cropping function works fine on mobile in XAMPP localhost environment.
    It would be great to know why it poses problem with Local by Flywheel, baring in mind that the ProfileGrid membership plugin with similar image cropping works well anywhere.

    I believe I just completed a session of troubleshooting the Ultimate Member plugin on behalf of its Development Team. You are welcome! 😉

    • This reply was modified 4 months, 3 weeks ago by  EugeneUK.
    • This reply was modified 4 months, 3 weeks ago by  EugeneUK.
    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi,

    Please update the Ultimate Member plugin to the latest version and see if the issue still occurs.

    I’m closing this ticket temporarily due to inactivity. If you’re still having an issue, just reply to this thread and mark this as “Not resolved” and we will continue the investigation.

    Regards,

    Thanks, but your response time to my enquiry is worse than expected.
    Good plugin!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.