[resolved] Problem posting to WordPress install in a subfolder (6 posts)

  1. volongoto
    Posted 1 year ago #

    I'm using StackEdit as my primary post editor. I have no difficulty posting to my wordpress.com blogs. But when I try to post to a blog that is hosted on my own domain (domain.com/blog), I never get to pass the authorization. Thye StackEdit interface displays an error message ("Access to WordPress account is not authorized.") and that's it.

    I have the following plugins installed:

    Akismet (3.0.0) Inactive
    Hello Dolly (1.6) Inactive
    Jetpack (2.9.3) Active

    I have checked the credentials I use many times. And the fact that I can post to a wordpress.com hosted site makes me think there is a problem with my self-hosted setup. In the error.log file I see the following line for every login attempt:

    [21-Apr-2014 18:56:20 UTC] WordPress database error Duplicate entry 'jetpack_nonce_1398106573_nglweK7adF' for key 'option_name' for query INSERT INTO 'gvm_options' ('option_name', 'option_value', 'autoload') VALUES ('jetpack_nonce_1398106573_nglweK7adF', '1398106580', 'no') made by do_action('login_form_jetpack_json_api_authorization'), call_user_func_array, Jetpack->login_form_json_api_authorization, Jetpack->verify_json_api_authorization_request, Jetpack->add_nonce

    Any ideas? Thanks in advance.

  2. Not sure if you seen this: http://wordpress.org/support/topic/unauthorized-user-cannot-publish?replies=6

    May be something to consider.

    Curios what your server setup up may be; I'm tempted to try something like that for documentation. :)

  3. volongoto
    Posted 1 year ago #


    Thank you for the response. I saw the thread you linked to before posting my question. But I'm not developing an application. I'm using an application (the application that is given as an example in that thread) to post to my WordPress blog. And while I can post to my wordpress.com blog, I'm not able to post to my self hosted blog.

    What do you want to know about my server setup? I can provide some more info if needed :)

  4. volongoto
    Posted 1 year ago #

    Here is some updates:

    I removed the Jetpack plugin and then removed both the blog and the database related to that blog. I also asked the wordpress.com team to remove my blog from the "My Blogs" list.

    Then I reinstalled WordPress 3.9. And without doing any customizations I installed the Jetpack plugin. And tried the authorization again. And I got the same error:

    WordPress database error Duplicate entry 'jetpack_nonce_1398281569_wuvqhWnORT' for key 'option_name' for query INSERT INTO 'pib_options' ('option_name', 'option_value', 'autoload') VALUES ('jetpack_nonce_1398281569_wuvqhWnORT', '1398281577', 'no') made by do_action('login_form_jetpack_json_api_ '), call_user_func_array, Jetpack->login_form_json_api_authorization, Jetpack->verify_json_api_authorization_request, Jetpack->add_nonce

    In short, this happens on a clean WordPress + Jetpack installation...

  5. What steps did you take? I was able to create a post with a clean install of both Jetpack and WP. I used a subdomain, though.

    -My steps:
    1. install WP
    2. install Jetpack
    3. Connect to WordPress.com
    4. Authorize self-hosted
    5. edit stackedit.io publish site to field
    6. New window pops up asking to connect to WordPress.com and what blog to connect to

    Have you talked to your hosting company about this?

  6. volongoto
    Posted 1 year ago #


    The steps you followed are exactly the same as my steps. The only difference is (as you mentioned) that I install to a subfolder.

    I tried a fresh installation on a subdomain after your post. And it works. No problems at all. So, there is probably something fishy with subfolder installations? I don't know. But I'm happy with my subdomain installation. Thank you very much for your help/support. Perhaps developers would like to create a ticket to investigate this issue further, but it's solved from my point of view. I have a working installation.

Topic Closed

This topic has been closed to new replies.

About this Topic