Support » Installing WordPress » Problem installing WP 2.8.4 (wp-load.php)

  • Resolved ziado


    Just wondering if anyone was successful installing version 2.8.4- this is my first time doing this, used FileZilla for ftp and as the host (supports PHP and SQL requirements). I keep getting error:

    Warning: require_once(../wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /usr/www/users/ziadrizk/wordpress/admin.php on line 22

    Fatal error: require_once() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.:/usr/local/lib/php’) in /usr/www/users/ziadrizk/wordpress/admin.php on line 22

    I think the ABSPATH is not being defined bec when I placed the line echo ABSPATH in the admin.php, i get the word ABSPATH.
    I also noticed that not all the PHP files end with ‘?>’
    Shouldn’t they?

Viewing 10 replies - 1 through 10 (of 10 total)
  • /wp-load.php
    you are sure this file is physically on the server and not 0 byte?

    Yes, and it has 2,393 bytes
    It is in the same directory as admin.php, wp-config.php and all the other WordPress files. I’ve also given all permissions to those files.
    Any other ideas?

    I am about to give up on WordPress. It is not a 5 minute installation

    Try to upload your wordpress installation file in ASCII mode instead of binary. You should change the mode from your FTP client.


    Thanks Kailash- but I did just that, uploaded the files in ASCII mode on the ftp client, and unfortunately I still get the same error. Could it be a problem with the web host I wonder ( My account should support PHP and I’ve setup the MySQL DB…. Any other ideas/insights are greatly appreicated, (getting desperate) Thanks

    I did a pair installation for a client earlier without hitch – so that probably isn’t it
    are you on a linux server?

    I’m running on windows XP on my laptop and uploading to Pair Networks which provides services exclusively utilizing the FreeBSD UNIX operating system- not sure if I’ve answered your question. Thanks

    I unzipped the tar file (instead of untarring) which put all files in one directory-flat structure. Now I suspect that that might be the cause of the problem as it seems that there are various subdirectory structures where the files out to reside- can anyone pls confirm? I also searched online for an untar utility but all were for Mac OS. Anyone knows where i can get one for Windows XP? Thanks

    the above was the problem- unzip with absolute directory path ( as stupid as it is, it took me 3 days to figure it out!) beware WinZip!

    Change the line



    require_once( ABSPATH . 'wp-load.php');

    I have to change this line with each upgrade. My error shows up in the file update-links.php.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problem installing WP 2.8.4 (wp-load.php)’ is closed to new replies.