Support » Plugin: Convoworks WP » Problem installing convoworks

  • Resolved lucavanon

    (@lucavanon)


    Hello, I tried several times to install convoworks plugin to fresh wordpress installations, but everytime it fails.
    After activating it, instead of taking me to the getting started page it tells me I have no permission to view the page. If I reload the page the page loads, however the plugin doesn’t work. When I try to connect to the Amazon account as I click connect it say page not found. If I try to create a new service a lot of errors turn on in a red modal window.
    I thought it was a server configuration issue so I tried on InstaWP, same behaviour.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    Hi,
    Thanks for reaching out. 
    
    Let us check the easier issues first.
    * "no permission" after activation - known issue, it will be fixed, but reload solves it.
    * There is known issue when using with InstaWP - you have to set "Settings/Permalinks" to "Post name". Not sure why is that, InstaWP founder told me that and after that it was working alright - https://convoworks.com/create-your-first-amazon-alexa-skill-using-convoworks-wordpress-plugin-and-instawp-no-server-no-registration-required/
    
    For other reported issues, were you using localhost installation or on a publicly accessible server?
    Thread Starter lucavanon

    (@lucavanon)

    Hi, thanks for your fast reply.

    *Ok, for no permission, thanks.
    *The “Settings/Permalinks” to “Post name” fix solved the issue for InstaWP.

    For the other installations I used a publicly accessible server, however I will try with “Post name” permalinks and let you know if it’s working.

    Thanks for your support. I’ll be back soon.

    Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    Glad to help! Besides that, it seems that we are in the same time zone 🙂

    We never encountered issues with regular installations, but the good part is that it is easier to troubleshot.
    Please check what PHP version you have on your server and you can try to enable log file like described in https://convoworks.com/using-the-convoworks-log-files/

    Thread Starter lucavanon

    (@lucavanon)

    So, I tried on an hosted website and it’s working.

    On the contrary, on my local server it’s not working.
    I’m running an apache2 server on linux (Antix), php7.3.
    The server is reachable through a dynamic dns service at this address: mikeros.ddns.net
    It is SSL certified with Letsencrypt.
    The plugin installs well (except for the no permission warning), but when I try to connect the Amazon account it says “Not Found – The requested URL was not found on this server.” (the page missing is “convo-connect-to-amazon”).
    The permalinks are set like you told me to “Post name”.
    I tried both from outside (internet) and from localhost, same result, trying to connect to Amazon get to a Not found error.
    Also trying to create a new service get a red modal window full of errors.
    Any idea?
    Thanks.

    Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    This is strange.
    Can you please send me the following
    – turn on log file and check in log file are there any error messages
    – when it lands on not found, please send me the url
    – please send me couple of lines, or screenshot from the modal on create service view

    Alternatively, you can schedule a call with me and we can check it using the share screen – https://calendly.com/convoworks/convoworks-demo

    Btw. Permalinks fix is only for InstaWP. I talked to the founder today and he said that they will fix that issue in a couple of days.

    Thread Starter lucavanon

    (@lucavanon)

    Thanks, I solved the issue myself!

    I found out that, for some reason in the configuration file of apache2 there was still “AllowOverride None”, probably I forgot to turn it to All.
    This alone fixed the issue.

    Many thanks for your supply!

    Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    Great to hear that!

    Please be free to reach for help if you have any other issues or questions with usage! You can ask here or below any article on our website.
    Happy Alexa development!

    Thread Starter lucavanon

    (@lucavanon)

    Thanks, I will.
    Just another question: is it possible to implement Italian language? (if it’s not already implemented)
    I could offer help for translations if needed…
    In the meanwhile I will speak English with Alexa.
    Thanks again!

    Thread Starter lucavanon

    (@lucavanon)

    Sorry, another question that probably could save me some time.
    I want to do a simple file player to start and I was wondering if there is the chance to set the folder where the mp3 files are stored in another location (for example a different disc/partition).
    Linux partition is too small to store all mp3s.
    Thanks in advance!

    Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    No, unfortunately currently just English is supported.
    We might have that feature in several months (we already had such inquiries) and we would appreciate your help with it.

    If you are inpatient, there is a workaround for it. It uses “manual mode” in Amazon Alexa configuration, meaning that Convoworks will not propagate any changes to the ASK console. Alexa skill in the ASK console has to be manually created and configured. There are a couple of more hints about it and if you are interested to try I can elaborate.

    Having mp3s on a separate disk should not be a problem. You just have to map that folder to be accessible through Apache. In “Filesystem mp3 source” context, use “MP3 folder path” to set a physical path from which Convoworks can read files. “Base URL” should point to the same folder, but through Apache.

    Thread Starter lucavanon

    (@lucavanon)

    Hello,
    finally I had some time to do some testing…
    I followed the tutorial for the Order Pizza app, but unfortunately I get stuck on the Configuration step.
    After finishing to build the app and save, I soon as I switch to the Configuration tab there is an error in a red modal popup that says: “e.join is not a function”.
    More than that, the Amazon Alexa box has the switch on off position and I’m not able to change its status.
    I also noticed that on the top right of the Convoworks window, beside the Auto propagate switch there is a dropdown box with “No platforms” as the only choice.
    Thanks in advance for the help.

    Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    Strange.
    Several things come to my mind.

    – what OS/browser do you use? We have a known issue with Safari on Mac
    – have you connected your installation with your Alexa developer account like described in https://convoworks.com/docs/publishers/platforms-configuration/amazon-alexa/
    – were you able previously to create skills on Alexa? Are they still working OK?
    – can you create new service from a template (e.g. Quote of the day) and publish it to Alexa?

    Thread Starter lucavanon

    (@lucavanon)

    – I used almost all browsers: Chrome, Firefox, Opera, all give the same result/error
    – The Amazon developer account is connected, doing the test says “Amazon is correctly configured”
    – I created one skill in Alexa a year ago, just to test my developer account, it’s still working
    – Creating a new service from a template (Quote of the day) gives the same error when moving to Configuration tab (e.join is not a function).
    Actually, ignoring the error and proceed with publishing to Alexa generate the skill on the Amazon developer console.
    Even if the skill is published to the console, testing on my devices fails (nothing appens on invocation), I believe the main issue here is the language localization.
    From the developer console I added a new language to the skill and try to replicate it in Italian language, I was not expecting it to work since the service is built in English, etc. but anyway I built the model.
    Something changes since on the invocation with the Italian name it compute something and then says thet there is a problem with connection and to try later.
    I tryed to add the endpoint (copy the address) to the “Europe and India” region and finally it worked!!!
    So, ignoring the error, I remember you mentioned a workaround to force the locale in Italian or something like that. Could you please help me to achieve it?
    Thanks

    Thread Starter lucavanon

    (@lucavanon)

    Just a small update.
    Applying the same strategy I created a music player and translate into Italian.
    Basic operations seem to work, like play, stop, next track, etc.
    What is not working is basically the search: Alexa doesn’t find any song I ask her.
    For simplicity I put the songs inside the website and I’m sure the service can find the files since the songs are playing, but the search give no result.
    Any suggestions?
    Thanks.

    Plugin Contributor Tihomir Dmitrović

    (@tolecar)

    About that search issue on your current version, can you please check in the ASK console, test view. That test view can not reproduce the audio player, but you can see the request on the right side. It should be “PlayTrackIntent” for an utterance like “ask file player to play Madonna”.

    How to set it up for non English languages:

    For this you have to configure Alexa in manual mode https://convoworks.com/docs/publishers/platforms-configuration/amazon-alexa/
    In that mode, all intents and utterances are defined and maintained in the ASK console. You even have to paste the url to your Convoworks service webhook there. That way you can set it up with IT language, while having EN in Convoworks.

    1. Create file player service in Convoworks
    2. Create Alexa skill, with enabled audio player interface.
    3. Connect your Convoworks service with Alexa in the manual mode.
    4. Go to Releases view in your Convoworks and copy endpoint url of your development version (button on the right)
    5. Paste that url to ASK. Now is a good point to check will it trigger a webhook in the Convoworks.
    6. In Convoworks, Import/Export view, download Amazon Alexa export. This is JSON, containing all required utterances. It should be quite easy to translate it directly here.
    7. Paste that JSON in the ASK console, Interaction / JSON Editor.

    Basically that should be that.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Problem installing convoworks’ is closed to new replies.