WordPress.org

Forums

Shortcodes Ultimate
Problem inserting shortcode in correct field using ACF, defaults to the_content (4 posts)

  1. lundnick
    Member
    Posted 1 year ago #

    I'm using ACF (Advanced Custom Fields)and have multiple fields and wysiwyg fields. I am not showing the default WP content editor. When adding a shortcode to a WYSIWYG it is inserted into the_content field which is the default area for the content editor.

    I would expect the shortcode to insert into the shortcode buttons wysiwyg window. Am I missing a way to target individual wysiwyg windows with shortcodes ultimate?

    I've utilized the shortcodes in many places before finding this handeling in the windows, I hate to have to go with something else.

    https://wordpress.org/plugins/shortcodes-ultimate/

  2. stermie
    Member
    Posted 1 year ago #

    I am having the exact same issue. This is an important usability problem as I do not want my admins to have to copy and paste the shortcodes from one field to another when they add them.

    It used to add the shortcode to the current custom field, but it stopped working after a recent SU plugin update (not sure which one). Now it adds the shortcode to the regular Content field in WordPress only, no matter what custom field I am trying to put it in.

  3. stermie
    Member
    Posted 1 year ago #

    Hello Vladimir,

    If you're looking, I need some help with this issue as this is a major problem/conflict with Advanced Custom Fields. Shortcodes Ultimate is only placing shortcodes into the default content field and not custom WYSIWYG fields. This seems to have changed with a recent update to SU, but I can't pinpoint which one. ACF seems to thing it is an issue with your plugin only targeting/working on the default content field.

    I'm not sure how to contact you any other way, so I am hoping that you see this.

    I can give you temporary access to the test site so that you can see what is happening if necessary, but I think I explained it as best as possible. It appears others are having this same issue.

    Any help you could provide would be awesome. I use your plugin for every site I create. I would hate to have to go to a different one for some of the same functionality.

    Thanks,

    Rob

  4. wpcsphil
    Member
    Posted 1 year ago #

    Same issue here :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Shortcodes Ultimate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic