WordPress.org

Ready to get started?Download WordPress

Forums

Problem in viewing recent posts from network site to main site (14 posts)

  1. amitabha197
    Member
    Posted 1 year ago #

    I have created a website in wordpress http://damiracle.com where there I already made a Blog Page. But the client wants to host the blog in a subdomain http://blog.damiracle.com and with different theme. So I made http://damiracle.com, the main and the network admin site after following all the procedure of Codex Creating a Network.

    After creating the Network I added a new site for blog which is in a sub domain named as http://blog.damiracle.com.

    I also installed WordPress MU Domain Mapping and WordPress MU Sitewide Tags Pages to view the Recent posts from the http://blog.damiracle.com to the http://damiracle.com but I am facing problem in viewing the posts from the blog.damiracle.com to damiracle.com. All the posts are viewing are the recent posts which are already inside the blog page of http://damiracle.com

    I know that I am going wrong but I can't figure out what wrong actually I am doing.

    Please help me.

    Thanks in advance.

  2. All the posts are viewing are the recent posts which are already inside the blog page of http://damiracle.com

    You mean the posts that are showing on blog.damiracle.com are the same as the ones on damiracle.com ?

    How did you setup wpmu sitewide tags? Which site is your 'tag' site?

  3. amitabha197
    Member
    Posted 1 year ago #

    Yes exactly. My tag site is blog.damiracle.com

  4. That's how it's supposed to work.

    The tags blog collects all the posts from all the sites and then links back to the parent site so if you click the title on blog.damiracle.com, it goes to damiracle.com if that's where the post is from.

  5. amitabha197
    Member
    Posted 1 year ago #

    I know that @Ipstenu but what is the problem is that when I am fetching the posts of blog.damiracle.com in my sidebar through Network latest post plugin I can see only a single post named Hello World and which is redirecting to 404 page of the blog.damiracle.com

  6. "Network latest post plugin" ... What one is that? This one? http://wordpress.org/plugins/network-latest-posts/

    Please understand, YOU JUST told me for the first time about this other plugin, so you have to remember that no one can help you if you don't tell us the full story :)

    So let's sum up, okay?

    1) You have a Tags blog (blog) that collects all the posts from all the blogs on the network. Does THAT work on it's own, yes or no?

    2) You're ALSO using a plugin (http://wordpress.org/plugins/network-latest-posts/) to display all post from the network on another site. This we know is NOT working. Likely it's because that plugin is only looking for the REAL posts on the tags blog, and not the ones the tags plugin put in.

    However... You don't need 'both'.

    Pick one. If you use the network latest posts plugin, you do not need the sitewide tags, because it should be able to pull in all posts on it's own.

  7. amitabha197
    Member
    Posted 1 year ago #

    I think I am unable to make you understand. Anyway I am explaining again.
    I have created a Network in my root wordpress site which is http://www.damiracle.com and created a site in my Network Admin named as http://www.blog.damiracle.com. My intention is to show the Latest posts from the http://www.blog.damiracle.com to the sidebar of http://www.damiracle.com.

    Previously I was maintaining a blog page in http://www.damiracle.com and the recent posts from http://www.damiracle.com is showing in my sidebar.But since I created the http://www.blog.damiracle.com I just want to show the Latest posts of http://www.blog.damiracle.com in http://www.damiracle.com.

    So to achieve this I installed the http://wordpress.org/plugins/wordpress-mu-sitewide-tags/ plugin, but I found the Latest posts from http://www.blog.damiracle.com are showing in http://www.damiracle.com.

    So I uninstalled the Sitewide Plugin and installed the plugin from http://wordpress.org/plugins/network-latest-posts/

    But after doing this I can see a single default post from http://www.blog.damiracle.com "HELLO WORLD" , but clicking in it it is going to the 404 page of http://www.blog.damiracle.com and also the other posts from http://www.blog.damiracle.com are not showing in http://www.damiracle.com

  8. It helps when you answer the specific questions. I asked them because I know Multisite very well.

    1) You have a Tags blog (blog) that collects all the posts from all the blogs on the network. Does THAT work on it's own, yes or no?

    You never answered that so I'm left to examine on my own.

    http://blog.damiracle.com/ (note NOT www, yes this matters) has a bunch of posts, all of which seem to work. Are those posts created directly on the blog site or were they imported per the tags plugin?

  9. amitabha197
    Member
    Posted 1 year ago #

    Yes those posts are imported

  10. amitabha197
    Member
    Posted 1 year ago #

    @Ipstenu I just visited your website. I am really honored and relaxed that you are taking care of my problem. Thanks

  11. Imported via the TAGS plugin or did you manually import them via WordPress's built in importer? :)

    The tags plugin would redirect you to the source blog.

  12. amitabha197
    Member
    Posted 1 year ago #

    Imported via via WordPress's built in importer

  13. Well... Okay, yeah, that's why :) You're not supposed to do that! Delete the posts you important. Now try to use the tags blog plugin to import!

  14. amitabha197
    Member
    Posted 1 year ago #

    OK @Iptensu Thanks I must try

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags