Support » Plugin: Rate my Post - WP Rating System » PROBLEM IN Rating Widget Settings

  • Resolved johnmarvel

    (@johnmarvel)


    PLEASE FIX A BUG FOR BUTTON “SAVE SETTINGS” in “Rating Widget Settings” not working and can’t change any setting if i want. example: Add rating widget to all posts, or Add rating widget to all pages, in Automatically position.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Blaz K.

    (@blazk)

    Hi @johnmarvel,

    thank you for reporting the issue. I double checked and saving settings works fine on test websites. Therefore I will need more information:

    1. Did you clear the cache after installing the plugin?
    2. What permissions do you have for the website? You need to be logged in as an admin to save settings.
    3. Which version of the plugin are you using?
    4. Do you get any errors when you try to save settings?

    Blaz

    yes all is ok from me but problem remaining.

    Plugin Author Blaz K.

    (@blazk)

    Ok but do you get any errors when you click on save settings? What exactly happens? Does resetting the settings work? Does the plugin work on the frontend if you insert the widget via the shortcode?
    It’s a tricky issue to debug and therefore I need more information about it.

    Blaz

    the plugin work via the shortcode YES. But with “Automatically adds rating widget to all your posts or pages” and the boutton “save settings” NOT WORK.

    I’m not reporting any bug report … and the button “Reset Settings” does not fix the problem.

    Plugin Author Blaz K.

    (@blazk)

    I’m just trying to figure out why exactly the plugin doesn’t work on your website. I cannot reproduce this issue on test websites and nobody else reported such an issue. So, first I need to know if the settings are successfully saved on your website, meaning that when you press save settings the plugin shows “settings saved”.

    Similar problem. Don’t save settings. Cache plugin deleted.

    Picture CMS: https://cloud.mail.ru/public/EFYo/hZMrQtFZY

    Plugin Author Blaz K.

    (@blazk)

    Hi @greendays,

    thanks for reporting the issue. Do you get any errors in console when you click save settings. Right click on the page in Chrome and then click inspect. Go to console and click save settings. If you get an error please send me the screenshot. I would very much like to fix this issue, but I was not able to reproduce it 🙂

    Blaz

    Plugin Author Blaz K.

    (@blazk)

    @greendays, you are getting internal server error and thus the php script does not run. Can you please check error log on your server and send me the screenshot or copy-paste the error here. If you have problems locating the error log, please ask your hosting provider for help. This would be really helpful.

    @blazk Errors logs:

    2019-02-26 02:37:21.903426 [NOTICE] [91.121.155.172:44817] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 02:37:21 2019] [error] [client 91.121.155.172] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 02:37:21.903487 [NOTICE] [91.121.155.172:44817] Content len: 95, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 02:37:21.903494 [INFO] [91.121.155.172:44817] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 02:37:22.649014 [NOTICE] [91.121.155.172:44871] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 02:37:22 2019] [error] [client 91.121.155.172] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 02:37:22.649070 [NOTICE] [91.121.155.172:44871] Content len: 101, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 02:37:22.649076 [INFO] [91.121.155.172:44871] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 04:46:44.598922 [NOTICE] [27.3.120.119:49655] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 04:46:44 2019] [error] [client 27.3.120.119] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 04:46:44.598967 [NOTICE] [27.3.120.119:49655] Content len: 92, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 04:46:44.598972 [INFO] [27.3.120.119:49655] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 04:46:47.099277 [NOTICE] [27.3.120.119:49776] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 04:46:47 2019] [error] [client 27.3.120.119] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 04:46:47.099333 [NOTICE] [27.3.120.119:49776] Content len: 91, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 04:46:47.099338 [INFO] [27.3.120.119:49776] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 08:45:00.884541 [NOTICE] [162.144.40.74:38224] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 08:45:00 2019] [error] [client 162.144.40.74] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 08:45:00.884582 [NOTICE] [162.144.40.74:38224] Content len: 95, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 08:45:00.884587 [INFO] [162.144.40.74:38224] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 08:45:05.718394 [NOTICE] [162.144.40.74:38870] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 08:45:05 2019] [error] [client 162.144.40.74] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 08:45:05.718433 [NOTICE] [162.144.40.74:38870] Content len: 92, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 08:45:05.718439 [INFO] [162.144.40.74:38870] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 11:24:05.375640 [INFO] [83.69.196.130:44084:HTTP2-129] Abort request processing by PID:2016837, kill: 1, begin time: 0, sent time: 0, req processed: 5
    2019-02-26 11:27:21.449474 [INFO] [83.69.196.130:44084:HTTP2-451] Abort request processing by PID:2026005, kill: 1, begin time: 0, sent time: 0, req processed: 2
    2019-02-26 11:40:35.478060 [INFO] [83.69.196.130:51527:HTTP2-53] Abort request processing by PID:2056952, kill: 1, begin time: 0, sent time: 0, req processed: 0
    2019-02-26 11:40:35.556520 [INFO] [83.69.196.130:51527:HTTP2-55] Abort request processing by PID:2056906, kill: 1, begin time: 0, sent time: 0, req processed: 4
    2019-02-26 21:48:23.920945 [NOTICE] [217.61.105.39:35200] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 21:48:23 2019] [error] [client 217.61.105.39] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 21:48:23.920980 [NOTICE] [217.61.105.39:35200] Content len: 95, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 21:48:23.920987 [INFO] [217.61.105.39:35200] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 21:48:25.168007 [NOTICE] [217.61.105.39:35858] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Tue Feb 26 21:48:25 2019] [error] [client 217.61.105.39] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-26 21:48:25.168047 [NOTICE] [217.61.105.39:35858] Content len: 92, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-26 21:48:25.168052 [INFO] [217.61.105.39:35858] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-26 23:13:57.193038 [INFO] [91.78.240.185:56452:HTTP2-191] Abort request processing by PID:3711400, kill: 1, begin time: 1, sent time: 1, req processed: 0
    2019-02-26 23:13:58.830625 [INFO] [91.78.240.185:56452:HTTP2-193] Abort request processing by PID:3711414, kill: 1, begin time: 1, sent time: 1, req processed: 0
    2019-02-27 05:02:06.865803 [NOTICE] [190.10.10.186:64824] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Wed Feb 27 05:02:06 2019] [error] [client 190.10.10.186] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-27 05:02:06.865853 [NOTICE] [190.10.10.186:64824] Content len: 95, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-27 05:02:06.865858 [INFO] [190.10.10.186:64824] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-27 05:02:08.644421 [NOTICE] [190.10.10.186:65182] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Wed Feb 27 05:02:08 2019] [error] [client 190.10.10.186] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-27 05:02:08.644473 [NOTICE] [190.10.10.186:65182] Content len: 101, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-27 05:02:08.644479 [INFO] [190.10.10.186:65182] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-27 05:04:07.923342 [NOTICE] [41.226.248.221:35204] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Wed Feb 27 05:04:07 2019] [error] [client 41.226.248.221] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-27 05:04:07.923376 [NOTICE] [41.226.248.221:35204] Content len: 93, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-27 05:04:07.923382 [INFO] [41.226.248.221:35204] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-27 12:12:00.590189 [NOTICE] [100.2.151.232:54910] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Wed Feb 27 12:12:00 2019] [error] [client 100.2.151.232] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-27 12:12:00.590246 [NOTICE] [100.2.151.232:54910] Content len: 87, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-27 12:12:00.590253 [INFO] [100.2.151.232:54910] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-27 12:12:01.109887 [NOTICE] [100.2.151.232:54962] mod_security rule [Id ‘4784627’] at [/etc/httpd/conf/security.conf:54] triggered!
    [Wed Feb 27 12:12:01 2019] [error] [client 100.2.151.232] ModSecurity: Access denied with code 403, [Rule: ‘REQUEST_URI’ ‘xmlrpc.php’] [id “4784627”] [msg “xmlrpc request blocked, no referer”]
    2019-02-27 12:12:01.109932 [NOTICE] [100.2.151.232:54962] Content len: 478, Request line: ‘POST /xmlrpc.php HTTP/1.1’
    2019-02-27 12:25:28.604099 [NOTICE] [109.107.126.19:42593] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Wed Feb 27 12:25:28 2019] [error] [client 109.107.126.19] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-27 12:25:28.604140 [NOTICE] [109.107.126.19:42593] Content len: 94, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-27 12:25:28.604146 [INFO] [109.107.126.19:42593] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-27 12:25:29.442330 [NOTICE] [109.107.126.19:42652] mod_security rule [Id ‘5000130’] at [/etc/httpd/conf/security.conf:24] triggered!
    [Wed Feb 27 12:25:29 2019] [error] [client 109.107.126.19] ModSecurity: Access denied with code 403, [Rule: ‘&HTTP_REFERER’ ‘@eq 0’] [id “5000130”] [msg “wp-login request blocked, no referer”]
    2019-02-27 12:25:29.442367 [NOTICE] [109.107.126.19:42652] Content len: 92, Request line: ‘POST /wp-login.php HTTP/1.1’
    2019-02-27 12:25:29.442371 [INFO] [109.107.126.19:42652] Cookie len: 37, wordpress_test_cookie=WP+Cookie+check
    2019-02-27 12:32:26.498718 [INFO] [83.69.196.130:36126:HTTP2-119] Abort request processing by PID:1536488, kill: 1, begin time: 5, sent time: 5, req processed: 3
    2019-02-27 12:56:23.008960 [INFO] [83.69.196.130:49185:HTTP2-419] Abort request processing by PID:1594324, kill: 1, begin time: 1, sent time: 1, req processed: 8
    2019-02-27 13:06:39.756226 [INFO] [83.69.196.130:40371:HTTP2-133] Abort request processing by PID:1620994, kill: 1, begin time: 0, sent time: 0, req processed: 2
    2019-02-27 13:09:19.701461 [INFO] [83.69.196.130:43572:HTTP2-5] Abort request processing by PID:1626930, kill: 1, begin time: 1, sent time: 1, req processed: 0
    2019-02-27 13:12:51.711029 [INFO] [83.69.196.130:49295:HTTP2-93] Abort request processing by PID:1636715, kill: 1, begin time: 0, sent time: 0, req processed: 2
    2019-02-27 17:32:34.866227 [INFO] [83.69.196.130:37540:HTTP2-119] Abort request processing by PID:2262727, kill: 1, begin time: 4, sent time: 4, req processed: 5

    Plugin Author Blaz K.

    (@blazk)

    @greendays thanks for sharing. This is a complete log and it’s hard for me to figure out which error is connected to Rate my Post plugin. Can you please try saving the settings and then send me the exact error – you’ll know which error is that by checking the time – new entry will be made at the time when you press save settings.

    @blazk
    [27-Feb-2019 15:21:49 UTC] PHP Fatal error: Call to undefined function wp_doing_ajax() in /home/p513118/www/visa-investora.ru/wp-content/plugins/rate-my-post/admin/class-rate-my-post-admin.php on line 132
    [27-Feb-2019 15:21:50 UTC] PHP Notice: Use of undefined constant ddsg_language – assumed ‘ddsg_language’ in /home/p513118/www/visa-investora.ru/wp-content/plugins/sitemap-generator/sitemap-generator.php on line 45
    [27-Feb-2019 15:21:50 UTC] PHP Fatal error: Call to undefined function wp_doing_ajax() in /home/p513118/www/visa-investora.ru/wp-content/plugins/rate-my-post/admin/class-rate-my-post-admin.php on line 132

    Plugin Author Blaz K.

    (@blazk)

    @greendays which version of WordPress are you using? I noticed that this function is only available since 4.7.0. So, if you update WordPress the plugin should work. I have to decide whether to update the plugin to support older versions or bump the required version of WP for the plugin.

    @blazk WordPress 4.6.7

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘PROBLEM IN Rating Widget Settings’ is closed to new replies.