Support » Fixing WordPress » Problem in importing TABLE

  • my blog is in non-english language. I have changed host provider so i took backup of data and saved the file on PC then as per help, i restored that tables by import command in phpmysql and file imported sucessfully, blog also get started but it is showing ??????? (question marks in entire blog) even though i have selected utf-8 format at the time of importing.

    how i can solve this problem ? please guide me

    thanking you in advance

Viewing 4 replies - 1 through 4 (of 4 total)
  • even though i have selected utf-8 format at the time of importing.

    More exactly where did you make that selection?
    Also, what was the encoding and collation in the old database? And what was the encoding of your blog?
    Further, did you open the backup (sql) file on your computer in some editor?

    All of the above situations are possible causes for getting “????” instead of special characters…

    At the time of importing, i have selected “choose file type” as UTF-8

    I have opened that backup file in notepad but it is 2.7 MB so Notepad gets hang. I have opened it in wordpad and it is showing me like this : ‘સાહિત્ય-લેખો’, (this is very similar to yahoo mail in local language. In yahoo mail when i see this type of character i ususally change encoding and mail become readable) but the problem is when i imported that file, it is showing me ????? on my blog.

    How can i check encoding and collection of my old database ?

    kindly guide me in detail.

    You shouldn’t worry ever what does it look like in the database… (never understod why people read DB 🙂
    If you still have access to your old DB, open it in phpMyadmin and on the very first/main page you’ll see the encoding and collation (not collection!).
    You should set your new database to the same!

    One more question: when you opened up the .sql file, did you make any changes and saved it? If yes, that might also be a problem if the file was not saved with the same encoding. (e.g. if originally it had all utf-8 encoding in it, but your wordpad saved it as ANSII… that’s not good!)


    My problem is still not solved.
    Please note that I have different version of mysql inside phpmyadmin.

    Old host prvoider was providing me : ver 2.6
    collation : uni_general_ci
    mysql charaterset : UTF-8

    New provider is providing me : ver 2.9
    collation : uni_unicode_ci
    mysql characterset : UTF-8

    Let met tell you in detail :

    when i Backup my data using BACKUP plugin, and then after setting collation etc same as like my past host, when i restore it, i can only see ??? marks in blog.

    If i do the EXPORT command of old phpmyadmin, and when i import it on new server, i can see the text (which is still better then above) but their format is not proper. I means shape of characters etc punctuations etc. I mean i am not able to see exactly as like my previous setting.

    All backups i have taken newly and i have not open any file in any editor.

    please guide me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem in importing TABLE’ is closed to new replies.