WordPress.org

Support

Support » How-To and Troubleshooting » problem formatting paragraphs

problem formatting paragraphs

  • Hey All,

    Since the 2.5 version of wordpress, I’n not able to format the paragraphs of my text any other way than inserting a [full stop]-dot and turning it’s color white.

    This might seem a somewhat weird way to format a text. And it is.

    Adding extra [enters] in my (visual) editor when writing doesn’t help.

    I’ve been browsing, reading suggestions about the html editor and/or the HTML clean up the wordpress editor uses.

    But this shouldn’t be important, since i rarely use the html editor.

    IS there anyone who can keep me from adding white dots to my text?

    Thanks and all the best,

Viewing 15 replies - 1 through 15 (of 23 total)
  • Since the 2.5 version of wordpress, I’n not able to format the paragraphs of my text any other way than inserting a [full stop]-dot and turning it’s color white.

    Sorry, not sure I understand.

    What’s a “[full stop]-dot”?

    I guess I understand that you’re having an issue, but I’m not sure what the issue actually is. Perhaps a few words on the end goal would be helpful?

    well,

    if i want to start a new paragraph, i used to be able to hit the enter once. or twice if i wanted even more space between paragraphs, if i’d start a new topic for instance, or bring in a new argument in a column.

    hitting enter would create more space between the last sentence of the previous paragraph and the first of the next paragraph.

    like this:

    first paragraph

    hit the enter-key

    next paragraph

    but, with 2.5, all the times i used the enter key to create space for a next paragraph, so as to make it more readable, all my enters are reduced to a single one.

    as a solution, i now insert “full stop”- dots: “.” where i want more space between paragraphs, and change the color of this dot to white. This way, it looks like there’s empty space between paragraphs.

    so my question is:
    is there a solution to the problem i have when formatting a text with the visual editor, when it “deletes” all my [enter] hits?

    thanks for your help.

    sid

    Easy, go to HTML formating. Use this code for a new line: <.br></br>

    **EDIT** Note – don’t put the “dot” in the brackets, I only put it there cause otherwise it reads it as a code and makes it appear as a new line in my post.

    2 new lines is <.br></br><.br></br>
    3 <.br></br><.br></br><.br></br>
    etc etc etc..

    Test and see how it works for you. ^_^

    nope! doesn’t work!
    (and shouldn’t there be an easier way than switching to the html editor? as in: just typing a couple of enters and actually see them reflected in your final post?)

    anyway, the [br] or [p] tags: tried that a long time ago.

    if you check out vollmer.nl and look at the last post for instance, you’ll see what i mean. i don’t know if you can view the page source, but trust me, i just inserted multiple [.br] tags between the first two lines.

    i found the location of the problem by the way:

    when, after adding [br] in the WP 2.5 html editor i switch back to the visual editor and click “save”, the [br]’s are gone…

    it’s with <> not with []. I am telling you from personal experience, that’s what I use for my blog.

    i know, that’s what i did
    <.br> or <.p>
    do not work…

    okay try it like this:

    paragraph1
    <.br></br>
    paragraph2

    On HTML, then Save and check if it works.

    Are you having the spacing between paragraphs issue in the editor or when displayed on your blog?

    If the former, I’d suggest re-copying the WP install files to your site to make sure you have everything and it is in the right place. While I’m not the biggest WYSIWYG editor fan, I know I don’t have to jump through hoops to get a paragraph break!

    Or, for that matter, disable plugins to see if you have a plugin causing problems.

    If the latter, what happens if you temporarily try the default theme? Is your theme not allowing spacing between paragraphs?

    the spacing problem appears in my editor already,

    everytime i save a post i am writing my enters are deleted.

    just today I upgraded to 2.5.1 -see if that would make a difference- to no avail.

    would re-copying install-files make a bigger difference than upgrading? or does that do the same as re-copying?

    i also tried to diable the plugins,

    and tried another theme.

    problem still occurs.

    @%$^&#!!

    Say, what browser are you using?

    firefox.
    but i’ve seen the problem occur on IE too…

    A proper upgrade should do the same as a re-install (depending on how you’re copying files).

    Did you delete the old files first or overwrite them?
    If you overwrote, maybe delete \wp-includes completely and then re-upload?

    If that’s not it, then I confess to being quite stumped and hope someone else might have some ideas. I don’t believe what you’re describing is normal or expected behavior. Just need to figure out why!

    well, i upgraded to WP 2.5 manually (i.e. making backups and using ftp to transfer all the files.

    problem with [p] started.

    i upgraded to 2.5.1. using installatron, an auto script install service my provider provides to me. that runs smoothly, WP recognises the update and doesn’t give me the “please update” message anymore.

    here’s a link tomy blog
    here’s a link to installatron

    thanks for all your suggestions handysolo, let’s hope there’s another WP user out there with advice!

    sid

    wtf?!?!?

    guess what I found out:

    other people, same problems

    lovely lovely people @ WP, you’ve made my life a lot easier by working so hard on free bloggin software. please fix this small little problem and i’ll buy you all icecream.

    <br class="blank" /> works for me as long as I stay in the raw HTML editor.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘problem formatting paragraphs’ is closed to new replies.
Skip to toolbar