Support » Plugin: Modula Image Gallery » Problem following update to v2.2.4

  • Resolved skyhawkpictures

    (@skyhawkmedia)


    Just to let you know that after updating from 2.2.3 to 2.2.4 of Modula, the settings that control hiding of captions and descriptions are automatically turned off (hence captions and desctiptions are shown). Also there is a whatsapp sharing icon on hover that is automatically turned on. I had to got through all the galleries on my sites and correct all these settings. Not great.
    Thanks
    S.

Viewing 15 replies - 1 through 15 (of 21 total)
  • I had the same issues. Also, when I click a gallery image, it shows the lightbox but now the page gets scrolled back to top, which is really annoying.

    • This reply was modified 1 month, 4 weeks ago by emersonwpdev.

    An additional issue, it is not possible to activate the plugin using the commandline (wp plugin activate) because it results in a fatal error. Class Not Found ‘Modula_Update’. I’m going to have to roll this thing back.

    Plugin Support mplusb

    (@mplusb)

    Hello @skyhawkmedia,

    Thank you for reaching out and letting us know about this.
    1. Regarding the captions and titles.
    I am not sure I understand this. Before the update you had the Hide Title and Hide Captions both turned on and it switched to off after the update?
    I tried to replicate this on my end but could not unfortunately.

    2.Whatsapp – this happens because normally the social media icons are set up by default to be turned on. Because we just introduced Whatsapp it’s displayed automatically because there were no previous settings for it (turned on/off).

    3. We did not test Modula using commandline, sorry about that. We will and fix it.

    Thank you,
    Mihaela

    Plugin Support mplusb

    (@mplusb)

    Hello @emersonwpdev,

    Can you please send me your gallery’s url so I can take a look?
    That should not happen.

    Thank you,
    Mihaela

    Hello, Mihaela.

    You can see the gallery here.

    Notice that when you click a picture, it has an empty anchor linked to it, like this. This behavior wasn’t there before, neither did we changed code for this site in a while.

    Thank you.

    Hi Mihaela,

    Thanks for your reply.

    Regarding the Whatsapp…now understood, I’ve now spotted the “Turn Social Off” switch which acts on all icons.

    Regarding the captions and titles, yes its exactly as you said (odd as it seems). I have Modula on two websites (one website has 3 separate galleries) and none showed titles or captions. Following the update, the options to hide captions and hide titles were both switched off for all galleries.

    Regarding the CLI, thanks. I’ll look out for it in the changelog before upgrading.

    Regards,
    Steve

    Confirming this was also my experience – a client emailed me to say all his images had titles showing on 5 or 6 galleries even though I had them all turned off!
    Regards, Dave

    Plugin Support mplusb

    (@mplusb)

    Thank you, @emersonwpdev!
    We have opened a ticket regarding this and we will fix it in our next update. Sincere apologies for the inconvenience!

    Plugin Support mplusb

    (@mplusb)

    @daveporter, @skyhawkmedia

    When you update did you previously had the latest version of the plugin? Or was it an older version?
    We are trying to replicate this on our end as well in order to find the issue.
    We are sorry for the inconvenience!

    Thank you,
    Mihaela

    • This reply was modified 1 month, 3 weeks ago by mplusb.

    Hi again Mihaela,
    I updated from 2.2.3 (and have rolled back to that now).
    Thanks
    S.

    Hi Mihaela,
    I’m pretty sure I ad the latest version – I tend to keep things up to date.
    Sorry I can’t be more certain!

    Dave

    Thank you for your support.

    Plugin Support mplusb

    (@mplusb)

    Hi @daveporter & @skyhawkmedia,

    Thank you for being so patient!
    We believe we found the issue you had and just released an update addressing it.
    It should work correctly now.
    If you rolled back to a previous version please update and let me know how it goes.

    Thank you,
    Mihaela

    Hi,
    I have updated to 2.2.5 and the “hide captions” issue appears to be fixed. Note however, that it’s not a true test because I didn’t roll back the database from the previous issue (in other words, my starting point for this update was code on 2.2.3 and db on 2.2.4)

    However, the more pressing issue (the reason I had to roll back) of the CLI activation is still NOT fixed. I still cannot activate the plugin from the command line, therefore I will need to roll this out – again. Same error – class not found Modula_Update

    Thanks
    S.

    FYI I have located the issue in your code (and also the additional issue that follows when that issue is fixed).

    The inclusion of the class_modula_update.php file sits within an if(is_admin()) block. This means that the file is NOT included when the plugin is activated from a command line. It is ONLY included from the dashboard activation.

    So I moved this code outside the IF block to see if it fixed the issue. It did, but it created a new issue. It appears you have introduced an activation redirect hook to direct the dashboard to the Modula plugin. This is, and has always been, a monumentally crap idea and I’ve never understood why any self-respecting organisation would use it. But either way it ONLY works with the dashboard interface. It throws up all sorts of warnings during command line activation.

    Get your act together guys, please.
    S.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.