Support » Plugin: iThemes Security (formerly Better WP Security) » Problem Error Lines when installing Ithemes Security plugin..

  • Hi all, I have uninstalled Wordfence to try Ithemes security plugin instead, but after installing Ithemes (without any trouble), when I tried to activate the plugin, then I had a bunch of error lines about “Itsec Tables errors” MariaDB and MySQL database etc… And I can’t manage to understand it all and fix it ..
    Any idea ? Thank you.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • It seems to be failing on the CHARSET/COLLATE when attempting to create the 10 plugin tables.

    ‘8859’ may not be a valid CHARSET.

    Valid CHARSET is for example ‘utf8mb4’. COLLATE is usually empty.

    Check for the lines below in the WordPress wp-config.php file:

    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8mb4' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    Thread Starter dani99

    (@dani99)

    Hello nlpro, you mean I must add this 2 lines to my wp_config and it should be fine?
    Thanks for helping, I really appreciate!

    Hi,

    If those lines are currently missing in the wp-config.php file, that may explain why WordPress is currently using a non standard CHARSET (8859) when attempting to create new tables in the database.

    However changing the CHARSET may have unwanted effects for data stored in the database ! So caution is advised.

    Probably best to log into the database with for example a tool like phpMyAdmin and then check the CHARSET for the existing tables.

    If the existing tables use for example utf8 then replace utf8mb4 with utf8 in the example wp-config.php lines and add them to your wp-config.php file.

    It makes sense to use the same CHARSET for all tables 😉

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.