Support » Fixing WordPress » Problem enabling Default Object Cache

  • I added define('ENABLE_CACHE', TRUE); to my wp-config.php file and I created a cache directory under wp-content with permissions 755. No files are appearing in that directory and the “server status” plug-in says:

    Page Cache (Plugin): Disabled
    Object Cache: Disabled

    Background:
    I have a long-running blog with WordPress 4.7. In the past it has has a number of cache plug-ins, including WP Cache, WP Super Cache, W3 Total Cache and most recently the Falcon caching engine in WordFence. Presumably all of those prior cache solutions have been removed according to the instructions that come with them.

    Things I tried:

    – Re-installing WordPress 4.7
    – Deleting an advanced-cache.php file I found in the wp-content directory
    – Deleting the wp-content/cache directory to see if WordPress would re-create it (it didn’t).

    Server status report:

    OS Type: Linux atl-d-11.cloudsites.vps.net 2.6.32-642.6.2.el6.x86_64 #1 SMP Wed Oct 26 06:52:09 UTC 2016 x86_64 (64 bit)
    Server Software: LiteSpeed
    CPU Cores: 4 Cores
    Load Average: 0.85, 1.3, 1.37
    IP (Hostname): 216.119.152.99 (atl-d-11.cloudsites.vps.net)
    Disk Space: 123.08 GB (79%) used of 156.51 GB total
    Database Size: 507.50 MB
    Database Name (Hostname): archko_conspiracy (localhost)
    MySQL Version: 5.5.52-cll
    Database Charset (Collate): (n/a)
    Document Root: [redacted]
    Theme Path: [redacted]
    WP Locale (Charset): en-US (UTF-8)
    Server Timezone (WP): UTC (America/New_York)
    PHP Version: 5.6.28
    PHP Extensions: Core, date, ereg, libxml, openssl, pcre, zlib, calendar, filter, gmp, hash, Reflection, SPL, session, standard, litespeed, bcmath, bz2, ctype, curl, dom, fileinfo, ftp, gd, gettext, iconv, imap, json, mbstring, mcrypt, mysqlnd, mysql, mysqli, PDO, pdo_mysql, pdo_sqlite, Phar, posix, SimpleXML, sockets, sqlite3, tokenizer, xml, wddx, xmlreader, xmlrpc, xmlwriter, xsl, zip, mhash, ionCube Loader, Zend Guard Loader, Zend OPcache
    Max Upload, Post Size (Input Vars): 2M, 8M (1000)
    Memory Usage: 16M (6%) of 256M (actual limit)
    WP Memory Limit: 96M (defined limit)
    WP Admin Memory Limit: 256M (defined limit)
    WP Debug: Disabled (no logging, display)
    Opcache Size (Max Files, Revalidate): 64M (2000, 2 secs)
    Page Cache (Plugin): Disabled
    Object Cache: Disabled
    • This topic was modified 2 years, 9 months ago by  kwdavids.
  • The topic ‘Problem enabling Default Object Cache’ is closed to new replies.