Support » Plugin: Pods - Custom Content Types and Fields » Problem displaying extended user fields

  • Resolved amytrecgb

    (@amytrecgb)


    I’ve extended my users with additional fields about their training and qualifications held in a custom table (wp_pods_user) and I’m trying to display these additional fields in a pods template on a page on my website, but limited to the current logged in user.

    I’ve created the template to show these fields however when I view the page as a logged in user the page is blank – it’s not even showing the field labels from the template.

    the shortcode I am using is:
    [pods name=”user” slug=”{@user.id}” template=”My Training & Qualifications”]

    I have got the define(‘PODS_SHORTCODE_ALLOW_EVALUATE_TAGS’,true); in my wp_config.php

    I can’t see any reason for this not to be working when I have other pages with a list of pods for the current logged in user. I’m stumped as to why this page is refusing to work.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @amytrecgb

    First of all, the ID of a user is not the slug field. Please use the id param.

    Secondly, keep in mind that using {@user.id} returns the currently logged in user, not the user you are currently viewing.
    If you need to current user you can just use {@id} or even easier, just omit the name and id params so Pods will use the current object automatically.

    Cheers, Jory

    I’ve tried with id=”{@user.id}” and no difference, tried omitting the id parameter but still the same. I only want to display the information for the currently logged in user, they should not be able to see other user’s information.

    this is the shortcode I have just tried: [pods name=”user” id=”{@user.id}” template=”My Training & Qualifications”]

    Any further suggestions?
    Thanks
    Amy

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Is it possible the “&” character in the template name is causing an issue? There may be an issue with shortcodes using that character.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Closing topic due to no reply.
    Feel free to re-open if you still need help!

    Cheers, Jory

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.