WordPress.org

Forums

Problem displaying background color with latest version (23 posts)

  1. Alexis403
    Member
    Posted 3 years ago #

    Hello,

    I just upgraded to the latest version of wordpress (3.3). All of sudden, the background color I had chosen for my site is no longer showing. I went to the "Background" section under "Appearances" to adjust it and save it again, but the background just remains white instead of displaying the color I have chosen. Can someone help me with this please? You can see my site here: http://www.findinghopewithin.com/

  2. Pioneer
    Member
    Posted 3 years ago #

    Is there also an option in your theme to use the theme options generated stylesheet or the default one?

  3. Alexis403
    Member
    Posted 3 years ago #

    I believe it is the theme options generated stylesheet. I can click on "Editor" and it will take me to the stylesheet for my current theme.

  4. Alexis403
    Member
    Posted 3 years ago #

    Is there something in the stylesheet I can change that will fix my problem? Please let me know where to go and what to change. Thanks.

  5. shirazdrum
    Member
    Posted 3 years ago #

    Line 15 of your css:

    #wrapper {
    background: #"color code here";
    }

  6. kmessinger
    Forum Moderator
    Posted 3 years ago #

    From the sticky above. Maybe this,
    THEMES WITH ISSUES

    Background images not showing

    Open header.php and locate your <body> tag. Change this value to <body <?php body_class(''); ?>>

  7. Alexis403
    Member
    Posted 3 years ago #

    Thank you Shirazdrum! It worked!

  8. shirazdrum
    Member
    Posted 3 years ago #

    You are welcome.

  9. Pioneer
    Member
    Posted 3 years ago #

    What happens now should the OP desire to use the themes options for css?

  10. n2h2o
    Member
    Posted 3 years ago #

    forgive me for not knowing, but i see the css brought up alot... where exactly is this located witin the site? I am having the same problem as the OP.thank you

  11. n2h2o
    Member
    Posted 3 years ago #

    added notify email

  12. Dee11
    Member
    Posted 3 years ago #

    I had the same problem with the background colour, it's fixed now! Thank you Shirazdrum! Top stuff! :-)

  13. Alexis403
    Member
    Posted 3 years ago #

    N2h2o, The css stylesheet is located under "Appearance" and then "Editor", there you will be able to adjust the code.

  14. shirazdrum
    Member
    Posted 3 years ago #

    Swanson,

    Obviously the theme option is not working, so adding a background color there won't change anything. Once the theme author fixes the problem and updates, then they can use that option again.

  15. Pioneer
    Member
    Posted 3 years ago #

    I went to the "Background" section under "Appearances" to adjust it and save it again, but the background just remains white instead of displaying the color I have chosen.

    I believe it is the theme options generated stylesheet. I can click on "Editor" and it will take me to the stylesheet for my current theme.

    @Alexis403, The editor in not the same as theme options (a set of options available with your theme). If you make changes to theme options and they do not 'stick', you have a problem with your installation and/or theme and/or plugins. While using the editor to modify a theme file may fix a minor CSS issues, that does not resolve the (yes, obvious) problem of theme options not working properly.

    @shirazdrum,

    Then we agree that the overall solution to this is not just theme file edits, but using a theme that works properly (and that the edits will have to be redone on each theme upgrade)?

  16. shirazdrum
    Member
    Posted 3 years ago #

    Swanson,

    They don't have to change anything. They are NOT removing the color code from their theme option. Whatever is causing that problem is just a glitch and when it goes away whether by theme update or plugin removal, the site will use the color code in the theme option instead of the edited one.

    Browsers ignore the identical classes and use whatever comes first in the stylesheet. Worst case scenario they end up with redundant background colors which has absolutely no measurable effect on speed, performance or look of the site.

    Also it's easier for me to give them a one-line change than sending them above their head looking for things they won't understand. They are happy that the color is back and I might be wrong, but I think that's all they care about anyway.

  17. Pioneer
    Member
    Posted 3 years ago #

    So you are assuming that when a theme option is changed the stylesheet is directly modified or is this set in the database and then called from a php file???

    I contentiously disagree that the OP should overlook the failure of the theme option to be set properly and highly recommend they review why this is occurring (and not just applying a quick fix).

  18. greenbeltlandtrust
    Member
    Posted 3 years ago #

    I do not know where on my css stylesheet I can change the background color. My background color worked fine til' about 2 months ago, when the background color went blank. I go into the theme's appearance/background section, and it shows the color I want, but not showing up on actual page.

    I looked through comments above, but jsut don't know where to insert my color number in my stylesheet. Website - http://www.greenbeltblog.org.

    Thanks for any info!

  19. kmessinger
    Forum Moderator
    Posted 3 years ago #

    I see the background in IE and FF. It is set to rgb (249, 249, 240); in style.css under body.

  20. greenbeltlandtrust
    Member
    Posted 3 years ago #

    The color should be green - #427222 (66, 114, 34 in RGB)(which is what it shows up as when I click background in theme). The color you are seeing is pretty much white.

  21. greenbeltlandtrust
    Member
    Posted 3 years ago #

    In body - I put RGB in as follows:

    body
    {
    background: #rgb(66,114,34);
    margin: 0;
    font: 76%/1.6em verdana, tahoma, arial, sans-serif;
    color: #000;
    text-align: center;

    Background didn't change to green, but text did. Oi vey. Help?

  22. kmessinger
    Forum Moderator
    Posted 3 years ago #

    Do a search for body in style.css. When you find the right one with the rgb, just put your values in. There is not a # before rgb.

    And for me, I just change one thing at a time so as not to overload my circuits.

  23. greenbeltlandtrust
    Member
    Posted 3 years ago #

    Thanks - I took out the # sign, and works great. I got text back to black as well. Thanks for help kmessinger!

Topic Closed

This topic has been closed to new replies.

About this Topic