Support » Plugin: WP Statistics » Problem Connect to WordPress RestAPI

  • Resolved swingerstaboo

    (@illatooscuro)


    I’m unsing centos 8 – php 7.4 updated to the last release.

    I’ve update the plugin and i receive first an error on php-math and was installed and resolved. Now i receive a Problem Connect to WordPress RestAPI.

    I’ve disabled caching plugin, i’ve tried also do disable firewall but the problem is persistent.
    I’ve update permalinks everytime i made a change and cleared cache.

    The same happened on another website i manage.

Viewing 15 replies - 1 through 15 (of 22 total)
  • skitpappa121

    (@skitpappa121)

    I’m having this error too, after updating to version 13.0.2. My other website runs version 12.6.13, and doesn’t have any issues with connecting to WP RestAPI.

    Plugin Contributor veronalabs

    (@veronalabs)

    Hi,

    Thank you for choosing our plugin.

    Please check out this ticket:
    https://wordpress.org/support/topic/error-occurred-while-updating-wp-statistics-v13-0/

    If you face another problem, please let us know and send us the error.

    Have a safe and nice weekend.

    Best,

    elesouef

    (@elesouef)

    Hi.

    Just updated to 13.0.2. Facing the same issue “Problem Connect to WordPress RestAPI.”

    Another website using 12.6.13 is ok.

    Thanks for your help.

    muhammadelashri

    (@muhammadelashri)

    I just upgraded now and got the error

    “Problem Connect to WordPress RestAPI.”

    and the ticked the plugin support referred to does not have anything to do with this problem and do not solve it.

    dbeee

    (@dbeee)

    Also have this problem and the post suggestion has nothing to do with my error either!

    Thread Starter swingerstaboo

    (@illatooscuro)

    @veronalabs the problem you linked has nothing to do wih our problem.

    I’ve tested on another VPS (Centos 7 + php 7.4) after upgrade i receive the same prolem

    This is the screen of statistics..

    https://ibb.co/3ycNNRr

    Just to let you also know.. if in the website is not present the php-bcmath the website is unreachable and brings everything down.

    Feel free to contact me to have admin access to a testing website where you can check yourself the problem.

    Anax

    (@pournaras)

    It’s the adblocker

    serge-wp

    (@serge-wp)

    Yep, you’re right Anax. Once I allow all “tracking + ads” on Brave (=my browser), Wp-Statistics (v 13.0.2) works fine.
    Seems silly though that I should need to allow myself to be tracked, just because I want to know visitor numbers to my own website.
    I hasten to add that this is possibly more of a “Brave” issue than one of WP-statistics, but it’d be nice to bring back the previous WP-statistics behaviour which worked fine with tracking and ads blocked while never interfering with the “Powerfull (sic) SMS solution for WordPress” ad.

    elesouef

    (@elesouef)

    So silly…

    Owosso Harpist

    (@owosso-harpist)

    That’s the problem! The Adblocker! Disable the Adblocker on your browser and the plugin will function like normal!

    Thread Starter swingerstaboo

    (@illatooscuro)

    I don’t have Adblock on firefox and the problem persists.

    Actually i reverted to the old version waiting for an official response from the support. (Disabling an ad blocker is not a solution, is a workaround even if it works)

    skitpappa121

    (@skitpappa121)

    If Adblocker is a problem in this new version of WP statistics, then Adblocker is NOT the problem!

    egitimaskinayonetim

    (@egitimaskinayonetim)

    I turned off adblocker, now it is working. Turn it off and clean the cache. But i don’t think the adlocker is a real problem for it. But worked 🙂

    Plugin Contributor veronalabs

    (@veronalabs)

    Hi,

    Thank you for using our plugin and we are really sorry about this.

    We are working hard to fix the issues and release a new version today. For now, the temporary solution is disabling Adblocker as some of you mentioned.

    Again, we apologize for any inconvenience this may have caused.

    Thanks for your patience and understanding.

    Best,

    studentsaver

    (@studentsaver)

    thanks Anax

    It’s the adblocker the problem ..

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.