Support » Plugin: WPBook » Problem: App "Pictopoetry is Unavailable"

Viewing 8 replies - 1 through 8 (of 8 total)
  • OK now it’s gone completely tits up.

    I have deleted the FB app and started again. I reinserted the details API key etc. into the plugin and now when I try to get permissions from WP Book it goes to a FB page with no content.


    Oh gosh, I am still struggling with this…

    I’m sorry. I have had it working but not any more.

    I have been through every step meticulously and it all appears to be working on FB but when I go to check permisions from my WP settings screen I just get an empty page. It has the header and right side bar but no blog.

    I tried a post as well and got this message.

    Caught exception in stream publish for user: Error validating application.Error code: 0



    Plugin Author John Eckman


    @hotmale – What’s your application url in Facebook?

    What’s the URL of the blog oustide FB?

    What do you have set as your canvas callback url?

    What version of WordPress are you running, and what version of WPBook?

    The fact that you can’t get the check permissions page means something fundamental is wrong.

    Is your Facebook app set for OAuth?

    Thanks John.

    Here are my settings.

      In FB

    App ID: ************466
    App Secret: **************************fa1a

    App name: pictopoetry
    Locale: English UK

      Website settings

    Site URL:
    Site domain:

    Canvas Page: pictopoetry

    tab name: pictopoetry
    tab URL: ?app_tab=true (this one I don’t really understand and have sometimes had it blank)

      Facebook app:

      In WPBook

    FB App ID: ************466
    FB App SEcret: ***************************fa1a
    FB profile ID: 523011847
    FB Canvas page URL: pictopoetry

    Still getting:

    Caught exception in stream publish for user: Error validating application.Error code: 0 after I post but the post still gets posted.

    With the OAuth thing I’m guessing that it is set up for that. After setting up the App there’s a page in FB that has an instruction to grant permisions and after that it gives a huge, long Access Token.

    WP version; 3.2.1

    This morning I have deleted the app, deactivate and deleted WPBook reinstalled everything followed the instructions as precisely as possible and it still won’t work.

    I still get this message on posting Caught exception in stream publish for user: Error validating application.Error code: 0

    After going through all that, I did it again. Still not working.

    Is it possible that something has been saved somewhere and is screwing up every install?

    Plugin Author John Eckman


    I don’t think that is possible – my guess is whatever error has occured just continues to occur.

    Did you re-grant permissions after reinstalling?

    What does your check permissions page show?

    Thanks for your interest John but I am afraid that I threw in the towel shortly after that post. I accept that it’s probably my error and not WPBook.

    What freaked me more was the announcement on your blog about the change in the Facebook API? I’ve been trying WPBook on someone else’s site/FB and not my own and didn’t fancy having to go back and sort this once it had gone live in the months ahead.

    Anyway, for now I am using RSS Graffiti and it will do. It isn’t nearly as good as WPBook. But now, I have just read a more optimistic comment of yours on your blog, and it appears that you are still developing WPBook?

    Thanks for everything.


    Plugin Author John Eckman


    Martin – no worries about giving up – between all the different potential configurations of WordPress and the constantly changing set of options in Facebook it is hard to figure out why it works well for some and not at all for others.

    I am hoping to continue developing WPBook, but the Facebook change to requiring HTTPS for Facebook applications (which they say they will begin to enforce October 2011) may greatly limit the number of people who can actually use it – to those who can run their blogs in https mode.

    In fact, I don’t even currently have the ability to run my blogs in https mode, as that requires a dedicated IP address and I’ve never felt the need to add the expense.

    So, it is uncertain at best how WPBook will operate post 10/1/11. It may be can I find a way to keep the wall posting and profile posting and comment import going, but forgo the canvas pages and tabs – but I’m not certain yet.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem: App "Pictopoetry is Unavailable"’ is closed to new replies.