WordPress.org

Support

Support » Plugins and Hacks » Easy Watermark » [Resolved] problem after upgrading to version 0.5.1

[Resolved] problem after upgrading to version 0.5.1

Viewing 14 replies - 1 through 14 (of 14 total)
  • Yep, same problem here 🙁

    And images can’t upload.

    I just downgraded from a backup, and warning went away…I suggest you do the same if you can, until a fix is posted…definatly a problem with the upgrade:)

    The same problem, anyone have the previous version to make available for download?

    Plugin Author szaleq

    @szaleq

    I’m sorry! I had to overlook some line of code… It will be repaired tomorrow. For now the solution is simple: go to all EW settings pages (ignoring all errors) and click “save” on each page, after that the errors should gone.

    Hey! do you know when this might be fixed? Mine is still doing the same thing–same Warning message and I am unable to access the media library/upload…etc.

    thanks!

    Plugin Author szaleq

    @szaleq

    Ok, I think I fixed this (just a typo in code, hope it was the cause of your problems). If you have access to your wordpress files (ftp or something) please download the 0.5.1 once again and just manually replace the plugin files (wp-content/plugins/easy-watermark).
    Alternatively if you are using version 0.5 or 0.5.1 currently you can remove the plugin and install it again (the typo caused the installation and deinstallation functions doesn’t work at all, so your settings should stay untached – however I can’t guarantee this)

    Please tell me if it succeed!

    Plugin Author szaleq

    @szaleq

    Oh, actually manual file replacing will not help, as it can’t repair already broken database… So if you see the errors, please remove the plugin and install again (your settings are probably lost already!)

    nope, seems worse if anything, sad to say. Just went to your plugin homepage and downloaded it, uploaded the files, got the following:
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/content/53/7370053/html/home/wp-content/plugins/easy-watermark/classes/class-ew-settings.php on line 95

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/53/7370053/html/home/wp-content/plugins/easy-watermark/classes/class-ew-settings.php:95) in /home/content/53/7370053/html/home/wp-includes/pluggable.php on line 875

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/53/7370053/html/home/wp-content/plugins/easy-watermark/classes/class-ew-settings.php:95) in /home/content/53/7370053/html/home/wp-includes/pluggable.php on line 875

    Tried deleting the plugin entirely, and reuploading the new version, and the same old error message came back. Had to reinstall from my backup version again

    Plugin Author szaleq

    @szaleq

    Maybe the plugin caused so much mess in its options, it cant be repaired…
    If you can open EW Settings page, please just click “save” on each settings tab (it will tell you there was an error, ignore it and just go back – settings were saved before the error has occurred). This will help for sure.

    I think I would rather just not upgrade and keep the version I have that works fine at the moment:)
    I tried completely deleting the plugin and reuploading the newer version, even if the options were messed up, deleting the plugin should have fixed that…
    I welcome others feedback and experiences though, if anyone has had a better time with upgrading, please add to this post.

    Plugin Author szaleq

    @szaleq

    As you whish. What I’m saying is the version 0.5 has also the typo which cause the installation and DEINSTALLATION functions doesn’t work at all. So even if you remove the plugin, all data in db are untouched.
    Another thing is I have just installed the version 0.5.1 on few sites and also tried to update from 0.5, and it works for me…

    another tip for advanced users: you can try to manually delete EW options from the database, just remove all entries from wp_options table which starts with ‘easy-watermark’ (delete * from wp_options where option_name like ‘easy-watermark%’)

    Plugin Author szaleq

    @szaleq

    ops it should be just “delete from wp_options where option_name like ‘easy-watermark%'”

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] problem after upgrading to version 0.5.1’ is closed to new replies.
Skip to toolbar