WordPress.org

Forums

Problem after Upgrading PHP (4 posts)

  1. Riddler
    Member
    Posted 10 years ago #

    This (presumably) isn't really a WordPress problem, but I thought I might get a better/quicker response here than elsewhere. I had WP up and working fine with apache_mod_php4 (4.3.6, I believe it was) and mysql 3.23, but then got the bright idea to upgrade mod_php4 to the latest version (4.3.10.21). After doing so and restarting apache, I now get a message from WordPress stating that my php installation appears to be missing the mysql required to run it. I restarted the mysql server, and nothing. I upgraded it to the very latest 3.23, and nothing. Where did I screw up? This is all being done under FreeBSD v4.9, using the ports collection.

  2. mattme
    Member
    Posted 10 years ago #

    Did you keep your old php.ini and was MySQL installed to same dir?

    You need to uncomment the following line in php.ini
    extension=php_mysql.dll
    and that file (comes with your MySQL installation in /php/ext/

    check you have enabled mysql and not msql or mysqll or anything.

  3. adsworth
    Member
    Posted 10 years ago #

    Hi Riddler,

    as far as I know under FreeBSD the php.ini is in /usr/local/etc somewhere and the extension is extension=php_mysql.so.

    Regards
    adsworth

  4. Riddler
    Member
    Posted 10 years ago #

    I got it sorted out. It turns out there had been some changes in the way the php4 port was installed, and extensions now have to be installed separately, from another port. If I had been paying any attention at all at the time, I probably would've figured this out, but I wasn't and I didn't. I appreciate the tips.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.