Support » Plugin: WP Deferred JavaScripts » Problem after update (array_merge(): Argument #2 is not an array)

  • Resolved Klaymen

    (@klaymen)


    On this page: wp-admin/options-general.php?page=wp-deferred-javascripts

    I’m getting this error:

    Warning: implode(): Invalid arguments passed in /home/*/public_html/*/wp-content/plugins/wp-deferred-javascripts/inc/admin.php on line 85

    In my website pages I’m getting this error:

    Warning: array_merge(): Argument #2 is not an array in /home/*/public_html/*/wp-content/plugins/wp-deferred-javascripts/inc/frontend.php on line 95

    https://wordpress.org/plugins/wp-deferred-javascripts/

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am having the exact same issue, everything was working nicely and then today it just broke. Please fix.

    Plugin Author Willy Bahuaud

    (@willybahuaud)

    The new version 2.0.5 will solve the issue you encountered 🙂

    Great, thanks!

    After update I’m still getting this error in wp-admin/options-general.php?page=wp-deferred-javascripts:

    Warning: implode(): Invalid arguments passed in /home/*/public_html/*/wp-content/plugins/wp-deferred-javascripts/inc/admin.php on line 85

    After entering a value (a script to not defer) and saving, the error is gone.

    Plugin Author Willy Bahuaud

    (@willybahuaud)

    Can you try to update the option field (into settings > wp deferred javascripts)?

    What do you mean with update? You mean click on “save settings”?
    I already tried that. In the first website where I have it, after entering a URL the error disappear.

    Second website: I entered the URL and I get a blank page with errors (one of them: header already sent). Then I come back to that page and entered it again, and bon, error disappeared and it is fine now.

    Hello,

    I see the same kind of issue after first install (I just discovered this plugin so no update yet).

    Install and activation => ok
    jquery.js added to “Javascript files to not defer” and save => issue appears (see debug traces)
    jquery.js added again to “Javascript files to not defer” and save => ok

    I don’t see it after uninstall/reinstall.

    WP 4.4.2 / WP Deferred Javascripts 2.0.5 / PHP 5.6.8 (local xampp & production) or PHP 7.0.2 (local uwamp and production)

    PHP Warning:  explode() expects parameter 2 to be string, array given in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 101
    PHP Warning:  array_filter() expects parameter 1 to be array, null given in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 101
    PHP Warning:  array_map(): Argument #2 should be an array in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 102
    PHP Warning:  array_map(): Argument #2 should be an array in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 103
    PHP Warning:  array_map(): Argument #2 should be an array in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 104
    PHP Warning:  array_filter() expects parameter 1 to be array, null given in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 105
    PHP Warning:  implode(): Invalid arguments passed in wp-content\plugins\wp-deferred-javascripts\inc\admin.php on line 85

    D.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Problem after update (array_merge(): Argument #2 is not an array)’ is closed to new replies.