WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Problem after moving hosts

[Resolved] Problem after moving hosts

  • renamecor
    Member

    @renamecor

    I had to change my host recently, and did all the necessary backups, but on re-installing onto the new host, only the front/home page is displayed.

    This is the site – http://www.weatherinturkey.org.uk, and you can see that all internal links are broken.

    I have tried to log into the blog, but get this message ;

    Parse error: syntax error, unexpected $end in /home/sites/weatherinturkey.org.uk/public_html/wp-admin/includes/post.php on line 554

    Can anyone advise.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You really need to upgrade from 2.7.1, as it’s very insecure.

    After that, disable your plugins. Check your Permalink settings. Switch to the default theme.

    renamecor
    Member

    @renamecor

    The problem being that I can’t even log in to do the things you mentioned. As stated in the original post, I get the error ;

    Parse error: syntax error, unexpected $end in /home/sites/weatherinturkey.org.uk/public_html/wp-admin/includes/post.php on line 554

    when I try to log in.

    Ok first, you might also want to check line 554 and the surrounding lines to see if you’ve not already been hacked. Have a look for any suspicious looking code.

    Otherwise, take a backup of your files and database (only FTP and myphpadmin access required):
    http://codex.wordpress.org/Backing_Up_Your_Database

    You can try temporarily just renaming your wp-content/plugins folder via ftp to see if that helps.

    You can also upgrade to the latest version with ftp without having to log in:
    http://wordpress.org/download/
    http://codex.wordpress.org/Upgrading_WordPress

    renamecor
    Member

    @renamecor

    OK I got it working. I checked the php file that was mentioned in the error – turns out everything after line 554 was missing. I found this out by comparing it to another WP install.

    After that, I could log in OK, but the links were still not working so I upgraded to the latest version and tried again. Still not working.

    I then went into the permalink settings, changed them back to ‘default’, saved the settings and then changed it back to ‘custom structure’ as /%category%/%postname%/ and saved the changes again.

    All works OK now, thanks for the suggestions, and hope this helps others.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Problem after moving hosts’ is closed to new replies.