Support » Fixing WordPress » Problem after 5.0 update with the classic editor

  • Resolved balancecharm

    (@balancecharm)


    Hello, after the update I installed the classic editor and now I have this problem. The tags do not work (you can’t add tags to the post, the window is there but it is not responsive) the settings tab is not responsive, the Yoast SEO window is there but it is blank and does not respond, also the screen options and help tabs at the upper right corner are not responsive either.
    So far, I tried to clear the cache everywhere, but that did not do anything. It is the same issue on both existing and new posts.
    Anyone else is experiencing something similar?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator t-p

    (@t-p)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    If that does not resolve the issue, try MANUALLY updating. Download WordPress again and unzip it, and use that to copy up. Access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. (NOTE: do not delete the wp-content directory or your wp-config.php file). Please read the Manual Update directions first.

    Backup: If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong. You can never have enough backups!

    nelson2018

    (@nelson2018)

    Hello Balance charm,

    I recently helped another wordpress user with this same issue so lets see if we can tackle this problem.

    2 methods that can help point you in the right direction

    Simply go to the Settings » Writing page in your WordPress admin area. You will see the option to do this under “Classic editor settings”. Don’t forget to click on the save changes button to your site settings. You will now be able to see a new link under the Posts menu to create new posts using the classic editor.

    If this doesnt help I found an external source for WP beginners here:

    https://www.wpbeginner.com/plugins/how-to-disable-gutenberg-and-keep-the-classic-editor-in-wordpress/

    If this doesnt help please try to disable visual composer. Once the other user I helped did that, classic editor was back and the “disable Gutenberg” plugin worked.

    [Signature moderated. Please don’t sign your posts, because we can see who you are via your name and avatar. That’s notification abuse. https://make.wordpress.org/support/handbook/forum-welcome/#avoid-signatures%5D

    • This reply was modified 12 months ago by t-p.
    Robert

    (@bob23894)

    Hi,

    For your info (if it may help somebody),

    After updating to WordPress 5.0 I had a problem with Gutenberg (not loading the content of previous posts and could not use it to create new content) and classic editor (was not able to see the content in view mode, but OK in text mode).

    I’ve tried with another theme. Same problem.
    I desactivated all the others plugins. Same problem.

    Then on my side it was not a problem of incompatibility between plugins or theme.

    But finally I solved the problem by adding a single line in wp-config.php

    See at https://www.wpbeginner.com/wp-tutorials/how-to-fix-white-text-and-missing-buttons-in-wordpress-visual-editor/ where I found the solution.

    Add the following line at the very top after the php opening tag in wp-config.php :
    define(‘CONCATENATE_SCRIPTS’, false);

    Now both Gutenberg and classic editor behave normally.

    balancecharm

    (@balancecharm)

    Hello everybody, thanks for your replies! I have tried to disabling all the plugins and switching to a default theme, the issue is still there. I have also tried to manually update the WordPress, but the issue is still there.
    Now, when I tried Nelson2018 solution, I actually discovered another problem. Whenever I go to Settings > Writing, I do not even have any setting related to Gutenberg or Classic Editor… It only has an option to switch between the classic editor and block editor, nothing about Gutenberg.

    Robert

    (@bob23894)

    Hi balancecharm,

    You’re right, the settings are “Default editor for all users” and “Allow users to switch editors” in writing, when you activate the Classic editor.

    But, you may install “TinyMCE Advanced plugin” to add functionality (such as which buttons (strong, italic…) to show in view mode).

    It’s working for Gutenberg and Classic Editor.

    balancecharm

    (@balancecharm)

    Hello, thank you very much everyone for your responses and suggestions. I have tried everything so far. The last thing I did, was re-install the WordPress 5.0. It said that I have Classic Editor activated (which is good), so there is no Gutenberg mentioned anywhere in the settings (which is normal according to Robert @bob23894).
    When I edit an old post or create a new one, the editor window looks and works as usual.I can update or publish the post. But the main problem is still there, which is not working tabgs, unresponsive menu items, such as Screen Options, Help, Settings, Comments… I also have Yoast installed and that is also unresponsive. Not sure what else to do.

    Robert

    (@bob23894)

    Hi,

    About unresponsive…

    Have you tried with another theme to see if the problem remains?
    Don’t forget to delete your cache (wordpress and browser, just in case)
    And desactivate plugins, one by one, and check if the problem is still there.
    As example, vaszeit says, about Yoast :
    “After some playing around, I discovered that Yoast plugin prevents Classic Editor and Disable Gutenberg from working properly. When Yoast is enabled, I get a blank editor window, even though there is content there. I also can’t add anything to that window as it’s completely unresponsive/disabled. When Yoast is disabled, the plugins work fine.”
    at https://wordpress.org/support/topic/incompatible-with-classic-editor-disable-gutenberg/

    IF Yoast is a problem at the present time, better to use another SEO plugin, such as
    “The SEO Framework” plugin (I’m using without any problem).

    supergeek6

    (@supergeek6)

    @bob23894 THANK YOU ROBERT!!! The wp-config line fixed my client’s site from the editor showing only white content and not allowing Visual or Text switching. I’m not sure if it’s the custom theme the site is using or a plugin conflict but being a live business site I did not want to disable plugins and themes during the workday. Everything looked fine to me after updating last night but I did not test editing any content (definitely will for other sites with this update now)! They reported the white screen error to me this morning and was worried because they wanted to post new content this afternoon. I followed the steps to edit the wp-config and now it seems the editor is working fine again!

    I set the Classic Editor plugin settings to default on classic and not allow users to pick the editor for now as well.

    If I can buy you a beer or a coffee I would be happy too as you just saved me hours! Thanks for your post!

    Robert

    (@bob23894)

    Very glad, supergeek6.

    I was happy on my part to find the solution on the WPBeginner website.

    Between you and me, I don’t really know, at the present time, why and how this solution is working “under the hood”!

    nelson2018

    (@nelson2018)

    happy all worked out

    balancecharm

    (@balancecharm)

    Hello, not sure why this thread was marked resolved. The initial problem “The tags do not work (you can’t add tags to the post, the window is there but it is not responsive) the settings tab is not responsive, the Yoast SEO window is there but it is blank and does not respond, also the screen options and help tabs at the upper right corner are not responsive either” that I have is still not resolved.
    I tried to completely de-installing Yoast as recommended by @bob23894 but the problem is still there, only without Yoast. I am still able to make new posts or edit the existing ones, just without the tags and settings.

    balancecharm

    (@balancecharm)

    Hey guys, I was able to resolve the problem! The problem was caused by Yoast plugin (unfortunately, because I used to love it…) well, looks like we will have to wait till they make it compatible. After deactivating the Yoast plugin, make sure to flush the cache! @bob23894 thank you for the recommendation!!!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Problem after 5.0 update with the classic editor’ is closed to new replies.