Support » Fixing WordPress » Problem after 3.1 upgrade

  • I did an automatic upgrade to 3.1 after backing up my databases and now the pages are not loading. I can get into the admin panels and I deactivated all plugins. When I go to http://www.domain name.com/wp-admin the admin page comes up without a problem. I reloaded PHP but that didn’t help. The pages are intact as far as editing them, but do not display. Does 3.1 require something else that the previous version didn’t? I had not downloaded 3.0.5 and had planned to do so when I saw 3.1 was available. I updated the theme I am using thinking the upgrade required the newest version of the theme.

Viewing 15 replies - 1 through 15 (of 54 total)
  • I suggest you provide a bit more info to help people help you.

    First, what version of WordPress did you upgrade FROM?

    Second, “pages are not loading” could mean several things. Are you getting 404s (Page Not Found), blank pages, browser hangs on loading or what?

    You might try saving your Permalinks again, as that sometimes solves some of the “pages not loading” scenarios I mention above.

    HOLY CRAP!!!! We upgraded and it DESTROYED our website?!?!?!?!

    http://prettyprincessgirls.com/

    The layout is a complete mess?!??!?! HELP! What do we do??!?!

    Restore from the backup you took before upgrading. If you didn’t take an backup yourself, see if your web hosting company provides one through cPanel or by contacting their support folks.

    Also, please create a separate thread, as it will get difficult to try and address two separate problems in one thread.

    I was using WordPress 3.0 when I did the upgrade to 3.1. Pages not loading is pretty vague, thanks. The browser hangs and never loads but I do not get a 404 error. The link is http://www.shastalibraries.org/staff
    and I have tried with the 2010 theme with all plugins disabled and still the browser hangs and never loads anything but does not error. I did try and resave the permalinks and all other general settings.

    @prettyprincess: your problem is likely a theme that has not yet been updated or tested with WordPress 3.1, as opposed to a bug in the new version.

    @grvogt: in Firefox, I get a more detailed error:

    The page isn’t redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    * This problem can sometimes be caused by disabling or refusing to accept cookies.

    This could be an .htaccess error. Saving permalinks is the first thing to try. If it doesn’t work the first time, rename .htaccess to test.htaccess and retry.

    You should also carefully investigate whether there are two .htaccess files, one each in the root and in /staff.

    The WordPress Codex should have more specifics.

    I’m also getting the infinite redirect loop after upgrading from 3 to 3.1. I’m running this on a Windows machine using the ISAPIRewrite module from Helicon. The permalinks were working fine prior to the upgrade and I’ve already tried resaving them via the admin and restarting IIS on the machine in case anything was being cached.

    I renamed the .htaccess file and resaved the permalinks and still the same thing. I am running on Windows Server 2003 as well.

    I’m afraid we are going to have to wait for a Windows expert to happen along to this thread. Everything I’ve said is based on Linux (web host) experience.

    I appreciate the help though. Thanks for the effort adiant!

    Any Windows folks have this problem and have figured it out by chance?

    I upgraded to 3.1 today from the previous version, and now I’m unable to upload images into my posts. The browser uploader keeps popping up when I try to add an image, and when I attempt to switch to the flash uploader I still get the browser version. I can see the photo in the media library, but the photo won’t automatically insert into the post. Plus when I do upload with the browser version, the photo upload doesn’t appear to be crunching, and makes me think nothing’s happening. Any clue as to what’s wrong? I’ve done things like clear my browser cache, logged out of wordpress, and even restarted my computer, but the same is still happening. My blog is pretty photo intensive, and I really need to try to fix this ASAP. Thanks! 🙂

    I’ve got the same problem after upgrading from 3.0 to 3.1. I can log into wp-admin ok.

    FIREFOX

    The page isn’t redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    * This problem can sometimes be caused by disabling or refusing to accept cookies.

    SAFARI

    Safari can’t open the page.
    Too many redirects occurred trying to open “http://blog.domain.com/”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

    DO NOT UPGRADE. This upgrade destroyed a website I was working
    on and was almost finished with! I have all my back-ups and have upgraded many wp before and this is the first time anything this borked has occurred. Has tried everything to re-install and backup to no avail. This sucks. Now I have to start all over again from scratch.

Viewing 15 replies - 1 through 15 (of 54 total)
  • The topic ‘Problem after 3.1 upgrade’ is closed to new replies.