Support » Plugin: Custom Post Types and Custom Fields creator - WCK » Problem adding Taxonomy terms in Guttenberg

  • Resolved byronyasgur

    (@byronyasgur)


    Hi. I have a problem adding taxonomy terms. I know that when adding a new cpt that I’ve created using WCK I can add the taxonomy terms in the right panel in Gutenberg ( typing and pressing comma ) and I can see those terms when I click on the taxonomy itself in the left WordPress menu but my problem is this is really all I can do. I can’t select any of these terms the next time I create a new cpt like I could if I create a new page or post; and when I go into a cpt that I have already created and added taxonomy terms to then they dont show up in any list so I cant see what terms are applied. Can you tell me how to manage this please? I made a new WP install to test this so it’s not any other plugins or themes.

    • This topic was modified 1 year, 1 month ago by byronyasgur.
    • This topic was modified 1 year, 1 month ago by byronyasgur.
    • This topic was modified 1 year, 1 month ago by byronyasgur.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello @byronyasgur

    I have just attempted to reproduce this problem on my test rig with no success so far.

    It works well here, I add tax terms when I edit a post, then I can see them in the list.

    Are you using a default taxonomy (tag or category) or a default one? If it’s custom, is it hierarchical or not?

    I have tested with a non-hierarchical custom tax.

    Best regards,
    Gabriel

    Yes actually you’re right and I can see the existing terms now – silly mistake on my part, sorry … but I still cant see how to pick from the existing terms anywhere, apologies if I’m missing something obvious

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi there,

    Do they show up as you start typing? That’s how non-hierarchical taxonomies are supposed to work — it’s the same for tags.

    Best regards

    Hi Gabriel

    Yes when the user has typed ( min 2 characters) it does display some … but then it filters the list based on those characters so there’s never a place to see the whole list like there used to be in WCK before Gutenberg … and actually since Gutenberg the regular WordPress posts DO allow you to see the full list in this way; it’s the exact same way it used to be before Gutenberg ( a checkbox list ) … so I thought It would be like that with WCK too.

    Bob

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi Bob,

    Where in the Gutenberg post edit screen can you see the full list of tags?

    Is there a setting or something to make it show?

    Because for me, by default, it’s still the empty box with tags starting to show up only after typing min 2 characters.

    Only for the hierarchical taxes (such as categories), I can see the checkboxes.

    For the non-hierarchical ones, I see no checkboxes.

    With the best of regards,
    Gabriel

    Wow – really sorry – you’ve been pointing at whether its’ hierarchical or non hierarchical all along and I kept missing it … I had created these as incorrectly as non-hierarchical so I was getting the expected behavior it’s just the first time I’ve developed a site with the new Gutenberg is what threw me I think.

    sorry forgot to mark solved

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    It’s all right 🙂

    Glad to help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem adding Taxonomy terms in Guttenberg’ is closed to new replies.