Support » Theme: Health-Center-Lite » Problem adding Image Widget to Home Page Service Section

  • Smartalk

    (@smartalk)


    Everything was working fine then I noticed that the formatting had changed on the Home Screen Service section. I deleted two Image Widgets and the problem disappeared. Re-added the Image widget and the problem returned.

    I looked at the resize_image.php Copy below:
    <?php
    if ( function_exists( ‘add_image_size’ ) )
    {
    //testimonial
    add_image_size(‘health_center_testimonial’,50,50,true);
    add_image_size(‘crop_hc_media_sidebar_img’,60,60,true);
    }
    // code for home slider post types
    add_filter( ‘intermediate_image_sizes’, ‘hc_image_presets’);

    function hc_image_presets($sizes){
    $type = get_post_type($_REQUEST[‘post_id’]);
    foreach($sizes as $key => $value){
    if($type==’health_testimonial’ && $value != ‘health_center_testimonial’ )
    { unset($sizes[$key]); }
    else if($type==’post’ && $value != ‘health_center_recentpostwidget’ && $value != ‘full’ && $value !=’crop_hc_media_sidebar_img’ && $value !=’health_blog_fullwidth’)
    { unset($sizes[$key]); }
    }
    return $sizes;
    }
    ?>

    I did have a similar problem that appeared at the same time after updating the Plugin memphis-documents-library. There was a problem with the plugin update which has been resolved by the plugin developer. Unfortunately the theme problem remains. Whether the two are related or it is coincidence that they appeared at the same time I’m not sure.
    I have spoken with the server technical team who confirmed that the problem was not server related but the program.

    I would appreciate any help and advice you can offer.
    Many thanks for your time and support
    Regards
    Steve (Smartalk)

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Problem adding Image Widget to Home Page Service Section’ is closed to new replies.