Support » Fixing WordPress » Problem 2.5.1 post_new.php and post.php

  • Hey guys i just made the upgrade process and i found that to create a new post using Firefox is very very slow, after access to post_new.php the web browser is soooo slow to scroll on the page. The same for edit a previous post.
    I tried on Safari too, and there appear to have and endless loading elements, in the status bar appear “loading 25 elements from 250” “loading 35 from 450” and it continue doing the same, the elements number just grow and grow and grow, if i tried to access to publish a picture it just never load.
    Anyone out there have seen this behavior?
    I disabled all the plugins just to check if theres a conflict, but even without plugins the problem still there.

Viewing 15 replies - 31 through 45 (of 67 total)
  • minute44


    I seriously can’t see an issue.

    When the save/publish area is in the “Saving Draft” state are you unable to do anything else? Like, does it lock up your edit pane or other tabs? Because mine doesn’t. It says “Saving Draft” for about 3 seconds then goes back to normal, during which time I am perfectly able to continue editing my post.

    Graham Smith


    Its not an issue for everyone, but for those that have it it is seriously painful. It does make using WP almost impossible.

    It doesn’t lock as such, but is kept in a perpetual state of activity.

    As we explain, once the first Autosave is triggered, the save button keeps reactivating/flashing etc, trying to re-submit the page. You can’t brbeak this sequance, so it basically slows the whole site down whilst it is continually make these ajax requests. During this you can’t make any edits unless you quite out and start over, until the first autosave starts, and then you have it all over again.

    It also affects any other browser tabs you have to a point where you cannot use any other web sites. You just have to close the whole browser window down.

    I have just fiddled with the autosave.js file and upped the time limit to some obscene number and this is now working. it doesn’t autosave and now I can use WordPress. It’s not ideal, but it seems to fix the issue until it can be resolved properly.

    Graham Smith


    Unelegant Fix Here for Autosave duration.

    Not being a coder, I decided to take a crack myself. I think I have found a make do hack, until it can be solved properly.

    Edit your ‘autosave.js’ file which can be found in ‘WP-includes’>’JS’>’autosave.js’

    There are some values on line 5-7:

    jQuery(function($) {
    	autosaveLast = $('#post #title').val()+$('#post #content').val();
    	autosavePeriodical = $.schedule({time: autosaveL10n.autosaveInterval * 1000, func: function() { autosave(); }, repeat: true, protect: true});

    All i did was take a guess and increase these values to some silly high number.

    So far, after creating a post and manually saving it, the autosave has not kicked in. This giving me time to actually write a post etc.

    Im not too sure what these values equate to in time wise, milliseconds etc, but it appears to work.

    You could try removing the complete ‘autosave.js’ file and see what happens, I may try that later. Just back it up.

    Hope that helps for the time being.

    [sig moderated]



    Man, it sounds like a real bitch!

    I wonder what the problem is… why some people experience it and others don’t…



    Add me to the list of people having this problem. I have 5 separate installations of wordpress blogs making up my website ( and I’m having this problem on only ONE of them.

    I’ve deleted the wp-admin and wp-includes folders and completely reuploaded them but it did not fix the flashing SAVE/PUBLISH problem. And the page hangs terribly.

    I am not a database expert and I don’t know squat about coding so I’m hoping someone much smarter than I am comes up with a fix soon, because my website is HURTING!

    Thanks guys



    You can try this to disable autosave (though I don’t know if that will fix this problem):



    Disabling Autosave hasn’t worked for me. Reuploading the files hasn’t worked for me. Short of a brand new install, I have no idea what else to try.

    Seems lots of people are having this problem, with no acknowledgment from WordPress that this issue even exists.



    yep that is the issue, WordPress has not chimed in at all.

    I can’t post anything or my blog goes offline.

    I am at a loss. WP 2.3 was a dream.



    Same problem here. My error_log has grown to more them 4000!!! pages and IE AND firefox consume 90% CPU capacity when editing a post. Evrything comes to a hold. I have tried to replece the admin-ajax.php with the old one from 2.5 but that did not help.



    I’ve had exactly the same problem of the buttons flashing and not being able to use the uploader, but after following ZeusII’s instructions carefully and reinstalling everything, it seems to work great now…

    Thanks ZeusII! 🙂

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    I have tried to replece the admin-ajax.php with the old one from 2.5 but that did not help.

    That’s because it probably hurt more than it helped.

    The only reports of fixing this problem so far have involved replacing the 2.5 files with the 2.5.1 files again. As in a full upgrade, or a reinstallation, or whatever it takes to ensure that the newer files are there and getting to the browser.

    Given this, and the fact that a fresh install does not exhibit the problems, the only rational explanation is a) incomplete upgrades or b) caching of old code either on the server or in the browser.

    I hate to keep beating this drum over and over again, but the evidence shows that this is likely the cause of a *lot* of people’s issues.



    Thank you Otto. I solved the problem here. It was caused by my own stupidity. When upgrading from 2.5 to 2.5.1 I replaced the wp-admin and the wp-include files but FORGOT the files in the root directory. After replacing that files too the problem was gone. I’m quite sure that I am not the only dumb *** here so probably others made the same mistake.



    I cannot say enough how much this bug perplexed me. I did many of the fixes here including changing the values in the autosave.js and even going the route of just plain commenting the entire file out. tried the return etc and had no success no matter the route.

    the only thing i can recommend is that you take some a deep breath and follow the same processes that your friendly SQA engineer has shed some light on.

    the script will probably be ready this weekend. btw



    Had this problem also, upgrading from 2.5 to 2.5.1.

    Is it a recognized fault for the developers?

    Experimenting with WordPress at the moment for a site launch and did my first upgrade – thought all went well until this issue came up. Glad to see I’m not alone although it is extremely annoying for all involved.



    The NoScript plugin for Firefox is an easy way to work around the issue.

Viewing 15 replies - 31 through 45 (of 67 total)
  • The topic ‘Problem 2.5.1 post_new.php and post.php’ is closed to new replies.