Proble with stylesheet (20 posts)

  1. karim rushdy
    Posted 2 years ago #

    I faced a problem today and my site is not uploading the theme properly. and I tried to reinstall it using the zip file but I got this message:
    "The theme is missing the style.css stylesheet"

    Can you kindly help me out!


  2. trich
    Posted 2 years ago #

    I, too, am having same problem...style sheet.css stylesheet missing. Forced to change theme.
    Please advise.

  3. WPyogi
    Forum Moderator
    Posted 2 years ago #

    I just installed the theme on a test site and it seems to be fine. Are you using the most recent version of the theme (looks like updated yesterday) and WP3.6.1?

  4. Mistra57
    Posted 2 years ago #

    Same Problem,.. cost me $15 to get restore files from Hosting Provider,...
    after I did the upgrade.
    Yesterday I did a new installation, (WP 3.6.1 and Graphene) Graphene was not working through WP. Installation failed with the same error message, but did work then by uploading the ZIP file and installing from it.

    Upgrading of the Theme (after upgrading to WP3.6.1) was the problem.

    If someone has a (different) solution to get this file back, or this problem solved please post,..Thanks

  5. karim rushdy
    Posted 2 years ago #

    Thanks for your feedback. I tried again today but graphene 1.9.2 does not install correctly (same message as posted on my first post).
    I hope someone will be able to solve this issue (i was very satisfied with the theme so far)


  6. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @karim rushdy - you could try updating it manually - see:


    @Mistra57 - did you not have your own backup of your site? That's always recommended before updating anything http://codex.wordpress.org/WordPress_Backups

  7. Mistra57
    Posted 2 years ago #

    @Karim,... thanks Karim!..also for your links,... appreciated
    I had aback up using for all my sites successfully WP-DBManager. As the name says it only backs up as My understanding is the content of the database and not the file system.

    Implementing the CSS file from the ZIP file, ...yes an option. The problem with this is if you don't run a child theme I guess all the custom CSS informatory and other adjustments are being saved the the now missing style.css file. Therefore simply FTP the original one back doesn't bring back the settings and adjustments stored in it.

    Not 100% sure if may assumption made above are correct but nonetheless updating the theme should not delete the CSS file anyhow.

  8. karim rushdy
    Posted 2 years ago #

    It WORKED !
    I deleted all theme files from my root directory and uploaded a fresh zip file from within WP.

    Thank you so much! you saved my day


  9. Mistra57
    Posted 2 years ago #

    I deleted the complete 'Graphene' folder and uploaded the backup folder(I paid for) and everything is working again.
    I'm afraid now to update the Theme which is running on 5 other domains, as I don't want to risk to go through the same thing again.
    I will back up in Graphene (Export function) the theme settings hoping that will do the trick in case I have to delete the other graphene folders too.

    I Hope the Graphene support guys create a fix soon.

  10. Artoforion
    Posted 2 years ago #

    This is the most awful thing that could occur today!
    We have a charity foundation bereg74.org and we help pregnant women and mothers with babies. Now we have no site and we can't help, because...

    The archive didn't manage to be established. In a subject there is no stylesheet of style.css .
    Installation of a subject wasn't successful.

    We beg! Correct the error!

  11. karim rushdy
    Posted 2 years ago #

    Hi Artoforion,

    I guess you faced the same problem as mine. try the following. first back up your files, then go to file manager in your control panel and delete the theme from the following folder:
    next, go to the graphene site and download a new copy to your theme.

    It worked for me, hope it does for you.

  12. Mistra57
    Posted 2 years ago #

    @Artoforian, @Karim @anybody else with this problem,...

    Please be advised that if you follow Karims well meant advise,in terms of deleting the graphene folder and install new, that you will loose all your customization for your theme, IF you don't have a Child theme installed as the customizations are saved in the style.css.

    Here is another option which works. In case you have done after finishing your customization of the me and "Export" of the "Graphene Theme Options", you can do as Karim described, by deleting and reinstalling and then importing your "theme options again. Works too.

    I run Graphene Theme on many of my clients websites and like it a lot, (until now ..;-))
    The best way I found so far and it worked for 2 installation is (if you not have one yourself) get a backup copy through your hosting provider.(which contains [only] the WP files)
    - Delete public_html/wp-content/themes/graphene
    - than replace the "graphene" folder with the one from your back up
    When you login into dashboard (for now) I would strongly recommend to not "update" Graphene theme again (if it shows up) until the issue is solved from Graphene themselves.

  13. karim rushdy
    Posted 2 years ago #

    Agree with you Mistra57

  14. Mistra57
    Posted 2 years ago #

    @Karim.... ;-)
    Good luck everyone please keep posting especially if you hear anything from Graphene..
    Thanks for all your comments and suggestions...

  15. Lee Woolsey
    Posted 2 years ago #

    Update to 1.9.2 totally broke in my installation too. DO NOT RUN THE UPDATE!

  16. Lee Woolsey
    Posted 2 years ago #

    After deleting the installed version and downloading installin gthe new it worked, but my customizations are lost.

    UPDATE: The theme was broken through the regular update process, but my customizations were not lost as I feared they would be. It appears to be working now.

  17. foolhandy
    Posted 2 years ago #

    I had the same problems and a broken WISIWIG editor.

    Deleted the Graphene folder manually and uploaded 1.9.2 taken from here:

    and it now all works perfectly again.

    There are instructions and a link to some background of the issue on the page linked to above.

    I am using a child theme so my customisations remained intact.

  18. ABCDiamond
    Posted 2 years ago #

    This problem only occurs on SOME updates to 1.9.2 but NOT to all of them.

    I have about 6 sites on Graphene. I updated 4 of them to 1.9.2, and one of them ended up with this broken stylesheet problem.
    I read about the various fixes, including using FTP, but chose my own easier option first.

    I went to APPEARANCE >> THEMES
    WordPress gave a message saying my theme was broken and switched to me the default one.

    In the Manage Themes section I then deleted the Graphene theme, using the delete option, but did NOT delete my child theme.

    In the Install Themes section, (2nd tab at top) I then did a new install of the Graphene theme.

    On completion of that, I activated the new Graphene install, and checked that it was OK.
    It was, so I then activated my graphene child theme, and everything was back the way it was before.

  19. ronangelo
    Posted 2 years ago #

    I have about 6 sites on Graphene. I updated 4 of them to 1.9.2, and one of them ended up with this broken stylesheet problem.

    Is it possible that a certain plugin on that one site has caused this or do they all have the same plugins?

    Or maybe only on users that use a child theme.

    I experienced this long ago with the graphene theme but in my case the culprit was a caching plugin.

  20. thebrett
    Posted 2 years ago #

    I also experienced a failed theme update. I had just updated WP to 3.6.1 and all seemed fine. Then I updated Graphene Theme and again all seemed fine. But within just a few minutes the site was unavailable. I could get to the back end where it showed missing theme. On further investigation I found there were missing files from graphene theme, including the main stylesheet(style.css). Luckily I do daily backups with updraft to dropbox. I restored it by overwriting the graphene theme folder with a backup via ftp. I will try again soon. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic