Support » Networking WordPress » Probelm with images in wp multisite

  • martinae

    (@martinae)



    Hi everyone,
    I have been reading a lot and for days but can not find the solution. I had my website http://www.imparoinglese.com for one year and last week i change to wp multiste, everything is ok except the fact that none of my thumbanil images or feature slides images are displayed on the home page. I have check my .htaccess and it’s fine, I contact my server and the Allowoverride is set in All, i can upload images and see them in the media but when I put them in the post they don’t diplay in the thumbanil on the homepage. Same for feature slides (my theme is Aggregate- Elegant theme)
    The server assitant sayed it my be a problem with upload path.
    MY FILE UPLOADER URL IS http://www.imparoinglese.com/en/wp-content/blogs.dir/2/files
    MY UPLOAD URL PATH IS http://www.imparoinglese.com/en/wp-content/blogs.dir/2/files
    MY UPLOAD PATH IS wp-content/blogs.dir/2/files

    Please someone can help?

    Thank you in advance

Viewing 15 replies - 1 through 15 (of 32 total)
  • John

    (@johngieser)

    martinae

    (@martinae)

    Thank you but I have already done all the checks:( and nothing change

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    i change to wp multiste, everything is ok except the fact that none of my thumbanil images or feature slides images are displayed on the home page.

    You mean here: http://www.imparoinglese.com ? I see slider images, so I’m not sure what you think is wrong.

    martinae

    (@martinae)

    No. http://www.imparoinglese.com is my “mother webiste” my child http://www.imparoinglese.com/en is the problem. Thnak you!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Your images are wrong.

    <img src="wp-content/blogs.dir/2/files/et_temp/londra-53998_74x74.jpg" id="about-image" alt="">

    That’s not correct. It should be

    <img src="http://www.imparoinglese.com/en/files/et_temp/londra-53998_74x74.jpg" id="about-image" alt="">

    Except somehow you broke THAT too and it’d have to be

    <img src="http://www.imparoinglese.com/wp-content/blogs.dir/2/files/et_temp/londra-53998_74x74.jpg" id="about-image" alt="">

    Given that these aren’t standard:

    MY FILE UPLOADER URL IS http://www.imparoinglese.com/en/wp-content/blogs.dir/2/files
    MY UPLOAD URL PATH IS http://www.imparoinglese.com/en/wp-content/blogs.dir/2/files
    MY UPLOAD PATH IS wp-content/blogs.dir/2/files

    Did you happen to change them? If so, please make a note and never change them again. You do not know better than WP in this case 😉

    martinae

    (@martinae)

    Actually I contact my server at the begging and they suggest me to change them because they said the Thumnail Url was different from the Url in the server. What should I do now? Thnak you so much for your help

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Kick your server and tell them they’re wrong, for starters. *sigh*

    First go back and fix this part.

    Fileupload Url: http://www.imparoinglese.com/en/files

    That’s what it should be, and your host needs to actually fix their stuff and not tell you WP is wrong.

    Second, make 100% sure your .htaccess is right. http://www.imparoinglese.com/wp-admin/network/setup.php has what yours should be.

    Third, none of that affects the fact that you’re putting in the image path wrong within the post:

    <img src="wp-content/blogs.dir/2/files/et_temp/londra-53998_74x74.jpg" id="about-image" alt="">

    Did you manually do that, or is your theme doing it?

    martinae

    (@martinae)

    First done.
    Second I am going to check now
    Third the only thing I did was when I follow the procedure to change to wp mu they said to create the blogs.dir folder. This is the only thing I did.

    martinae

    (@martinae)

    Sorry to bother you again but I just checked .htaccess file and I think there is something wrong. This is what it is
    <?php
    /**
    * Network Setup administration panel.
    *
    * @package WordPress
    * @subpackage Multisite
    * @since 3.1.0
    */

    /** Load WordPress Administration Bootstrap */
    require_once( ‘./admin.php’ );

    if ( ! is_multisite() )
    wp_die( __( ‘Multisite support is not enabled.’ ) );

    require( ‘../network.php’ );

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    That’s not your .htaccess. Double check you’re looking at the right file 🙂

    martinae

    (@martinae)

    Hi Ipstenu,
    This is my .htaccess file from public_html

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(contenuti|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    The one i gave you last night was the setup.php file from http://www.imparoinglese.com/wp-admin/network/setup.php.

    In public_html I have also a .htaccess_bak file that is like that

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    I really don’t know how to fix this problem:((

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Let’s tackle the elephant one bite at a time 🙂

    Third, none of that affects the fact that you’re putting in the image path wrong within the post:
    <img src="wp-content/blogs.dir/2/files/et_temp/londra-53998_74x74.jpg" id="about-image" alt="">
    Did you manually do that, or is your theme doing it?

    Third the only thing I did was when I follow the procedure to change to wp mu they said to create the blogs.dir folder. This is the only thing I did.

    When you inserted images into your posts, how did you do it?

    I’m asking because if you used WP’s tools, it would NEVER have started with wp-content. WP always uses an absolute, full, URL. So somewhere you did something odd, and I’m trying to sort out where so we can un-do it 🙂 You may have to go back and manually edit all your posts.

    martinae

    (@martinae)

    I insert images in my posts through the media button on the post page and I upload them from my computer, they are the same images I have used on my “mother” website.
    When the other day I was speaking with my server helper he asked me my wp adim login to check the setting and he said he try to change it as the thumbanil url was
    http://www.imparoinglese.com/home/imparoin/public_html/wp-content/blogs.dir/2/files
    While the server has
    http://www.imparoinglese.com/wp-content/blogs.dir/2/files/
    Maybe he did change.
    I just check the setting on my “mother” website (where i don’t have any problem and the upload path is wp-content/upload

    I tryed to contact my theme as well for support.
    oh:(
    thank you

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Oy.

    Okay, your server ‘helper’ isn’t helping.

    You get to go in, manually, to each and every one of your posts with broken images and fix them.

    Change this: "wp-content/blogs.dir/2/files/et_temp/londra-53998_74x74.jpg"

    to this: "http://www.imparoinglese.com/wp-content/blogs.dir/2/files/et_temp/londra-53998_74x74.jpg"

    martinae

    (@martinae)

    Thank you, I will do that and hopefully it will fix it! I will let you know:)Thank you again.
    Martina

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Probelm with images in wp multisite’ is closed to new replies.