[resolved] Prob installing WP on Mac 10.6.8 using MAMP. Can't see WP Admin page. (7 posts)

  1. fluttershutter
    Posted 2 years ago #

    Hi guys!

    Ok I need laymens terms going forward as I am not a coder, am a photographer. :)

    For the last few nights I've been trying in vain to follow the 'how to's' on installing WP on my Mac, so I can sort out the mess that is my new website, after I transferred it to a new domain name.

    I installed MAMP 2.1.1 and followed guidelines from: http://egalo.com/2012/05/15/clone-live-wordpress-to-local-env/ on chaning the 'localhost' url to a familiar one e.g. http://mywebsitedev.co.uk

    I used FTP to download my root directory from my webhost, including the current install of WP and I logged into PHPmyadmin and downloaded my database as an .sql file.

    I went to MAMP and PHPmyadmin, which I'd installed there and created a new DB table as per instructions and imported my database file downloaded above. It said 72 items had been successfully imported (or something like). I can see them in the table.

    My port is currently set to 80 for Apache and 8889 for MYSQL. I'll describe what I see in each of the key url's.

    Ok on my main domain name (changed in terminal from localhost:8888 to mysitedev.co.uk) so on page http://mywebsitedev.co.uk I see my logo and a html list of my page names and media file names in hiercharchy. If you click into anything though, you just get : Not Found

    The requested URL />/fine-art_editorial/fine-art-gallery/ was not found on this server.

    If I enter: http://mywebsitedev.co.uk/MAMP I see the MAMP interface and '
    Welcome to MAMP

    If you can see this page, MAMP is installed
    on your Mac and everything is working!' I can go to the tabs like PHPmyadmin and see my database, click into it and see files listed from WP.

    BUT if I go to http://mywebsitedev.co.uk/wp-admin I cannot get into the admin panel of WordPress to do anything to my site. Therefore I can't get to the part on Fixing the WordPress URLs and beyond, which is in the dashboard and settings!

    You can see some screenshots of the above here:

    I checked in my System pref's /sharing that I wasn't sharing any other sites using web sharing before I changed my port number.

    I am stuck now. Any thoughts? Thanks in advance!

  2. fluttershutter
    Posted 2 years ago #

    Ok so I checked my security settings on my mac and in firewall, which is turned on, I saw one connection for nmbd was not allowing incoming connection whereas there are two msqld connections allowing connection. I turned on nmbd and now I can see the wp-admin screen when I put in e.g. http:testsitedev.co.uk/wp-admin.

    I logged in but now I see the dashboard without the interface, so just the html files and placeholders for images. I guess then that the path to these is not being found. I really don't know what I'm doing but I think it is getting closer to being resolved. Any help still appreciated?

  3. egalojames
    Posted 2 years ago #

    BUT if I go to http://mywebsitedev.co.uk/wp-admin I cannot get into the admin panel of WordPress to do anything to my site. Therefore I can't get to the part on Fixing the WordPress URLs and beyond, which is in the dashboard and settings!

    If the site URL's stored in the WP DB are wrong - i.e. they use a domain that no longer resolves your site - then you won't be able to fix them in the dashboard because that will be inaccessible until the URL's are fixed. In this case, you can fix them directly in the database by running some SQL in the "SQL" tab of phpMyAdmin, as I described in Fixing the WordPress URLs.

    Until the site URLs in the DB are fixed, the symptom is that many of the links generated by WP go to the old URL, and if you try to log in then login page redirects you to the old URL as well. But apart from that, the site basically "works" outside the admin pages. If you're seeing directory listings then that points to another issue - I'm not sure what that issue is, but I'd suggest fixing the URLs in the DB first and then see what happens.

  4. fluttershutter
    Posted 2 years ago #

    Ok I've fixed it! God know's how but I found this article: http://www.craniumstorm.com/how-to-move-a-wordpress-site/ and followed step 4 about the ninja monkeys? I inserted the two lines of code into my local copy of PHPmyadmin after selecting my database and input my old live url and my new local url and then tried logging into my WP admin dashboard. It asked me to log in again but didn't seem to want to take my password, as in nothing happened when I put it in. But then I tried the root url again and it took me to the dashboard with everything as it should be! All my media files showing and theme and everything!

    Am just regenerating my thumnails now.

    It still would be interesting if someone could provide an analogy for my visual self, as to what exactly I did to get the thing to understand itself? Just so I remember for next time I move a site using MAMP.

  5. Matt
    Posted 1 year ago #

    Hi there, i'm getting this problem too and running appropriate SQL but i'm getting an error saying that wp-options doesn't exist, any ideas?

    Great tutorial by the way, it was very well explained and helped me no end. If I can fix this final little snag i'll be the happiest man alive!

    Many thanks!

  6. egalojames
    Posted 1 year ago #

    Maybe you need to select your wordpress db before running the SQL?

  7. Matt
    Posted 1 year ago #

    Hi there. I definitely have the database selected but still getting the same error message.

    The error message is this:

    #1146 - Table 'focus_one.wp_options' doesn't exist

Topic Closed

This topic has been closed to new replies.

About this Topic