WordPress.org

Forums

HTML5 jQuery Audio Player
[resolved] Pro-version: only sample player is viewed (29 posts)

  1. dcgroshek
    Member
    Posted 2 years ago #

    Allow me to preface by saying I'm completely new to WordPress and don't speak a lick of code.

    http://www.tonigroshek.com

    Problem: my managed playlist isn't viewable on page, only sample player is embedded.

    Fixes I've tried: I disabled all other
    plug-ins, as you suggested on other posts, with no change. I have both the mp3 and ogg files uploaded to my media library.

    Prt Sc page set-up: http://tonigroshek.com/?attachment_id=227

    Prt Sc of player embedded: http://tonigroshek.com/?attachment_id=228

    I've seen you suggest that spaces in the "file names" be removed. Please explain which file names you're referring to......the name of the media file stored in my library?...the name of the song listed in my managed playlist?...the name of the file in my page permalink?

    Please excuse the basic nature of my inquiry and thanks for any help/suggestions you can offer.

    http://wordpress.org/extend/plugins/html5-jquery-audio-player/

  2. dcgroshek
    Member
    Posted 2 years ago #

    My apologies.....forgot to note that I'm using:

    WP version 3.5.1
    Plugin version 2.0
    http://www.tonigroshek.com

  3. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Hi dcgroshek... no worries, we all start somewhere!

    Usually when the sample player shows it is a problem with the shortcode... so let's work through the possible problems:

    1. Check to see you have inserted the shortcode properly. I can see you're using the Pro player so you need to create a playlist, add songs, and then find the playlist shortcode and copy and paste that into the page.

    2. Check to make sure you haven't got any funny characters/symbols or spaces in the title of your playlist, or in the names of mp3/ogg files themselves (eg you should title a file mysong.mp3 not my song.mp3 or my#song.mp3)

    3. I can see in your screenshot that you haven't got the shortcode in the page itself... so I'm guessing you're using the widget? If so, did you go to Appearance > Widgets and set the playlist in the widget? Because if not then that would be why it is showing the sample playlist instead of your own playlist...

    Let me know how you go with these steps

  4. dcgroshek
    Member
    Posted 2 years ago #

    Thanks for your gracious reply Enigma.

    I've inserted the playlist shortcode into the page , which I hadn't done before contacting you. Thank you. Here's the screenshot of that.
    http://tonigroshek.com/?attachment_id=232

    I think I have the playlist correctly assigned to the widget?? Screenshot here: http://tonigroshek.com/?attachment_id=235

    Reading your other forum posts, it sounds like your plugin works best when NOT used in a widget? I tried to move the player widget into the "inactive" space, but that didn't seem to do anything.

    Let me make sure I've correctly implemented my media by letting you know that I added each mp3 file and ogg file into my media library first, then assigned each permalink in the correct field for the update song page for the player. Screenshot here: http://tonigroshek.com/?attachment_id=237

    Did I walk through THAT process correctly?

  5. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Yup you did the process perfectly right. :-) And this has identified clearly what the error is.... it is a problem with what you've entered in the mp3 and ogg link fields.

    Referring to this screenshot you sent: http://tonigroshek.com/wp-content/uploads/2013/03/update-song.png

    I can see you have not linked to a proper URL (file path) to your music files. It should look something more like this:
    http://www.tonigroshek.com/wp-content/uploads/2013/03/SongTitle.mp3
    http://www.tonigroshek.com/wp-content/uploads/2013/03/SongTitle.ogg

    So you need to upload your mp3 and ogg versions of the music files to your server (you could do that via Media Library in WP) and then locate the full URL filepath to those files (if you did if via Media Library then click on the file, and over to the right you will see the URL). Then you can paste the URL in to the mp3 and ogg fields in the plugin songs area.

    Let me know how you go...

  6. dcgroshek
    Member
    Posted 2 years ago #

    Surely, you'll be rewarded in heaven for dealing with my incompetence!!! We're one step closer, but please secure your patience cap : )

    I found the error you outlined re: the incorrect URL filepaths for each mp3/ogg file and corrected each one, but still no luck.

    I have the player assigned as a right side bar half page widget:
    http://tonigroshek.com/wp-content/uploads/2013/03/player-as-right-side-bar-half-page-widget.png

    Here's how I have the sidebar info set for the "listen & download" page:
    http://tonigroshek.com/wp-content/uploads/2013/03/listen-and-download-sidebar-info.png

    Now I don't even have the sample player. Here's what the page currently shows:
    http://tonigroshek.com/wp-content/uploads/2013/03/listen-and-download-page.png

    Perhaps your next gracious reply will put yet another puzzle piece in place. Please know that I'm studying WP on my end with youtube videos, support forums and the "WordPress For Dummies" resources (I'm their poster child!).

  7. dcgroshek
    Member
    Posted 2 years ago #

    Let me give you more background info, if that might be helpful looking at the puzzle pieces.

    I have each mp3/ogg loaded in my GoDaddy file manager, having uploaded it from my harddrive:
    http://tonigroshek.com/wp-content/uploads/2013/03/FTP-file-manager.png

    I also have each mp3/ogg file uploaded to my WP media library, having also uploaded each one from my harddrive.

    Perhaps I should delete all the GoDaddy files and re-upload them to that managed file from my WP media library instead of my hard drive???

  8. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    haha ok moving on then...

    1. Give your audio files proper names... I can see in your file manager screenshot that you have spaces in the titles. In general with web stuff you really need to avoid characters and spaces... use a dash or an underscore instead of a space.

    2. Make sure you filepaths are correct. So one I can see would be:
    http://tonigroshek.com/wp-content/uploads/2013/02/Like-Her.mp3
    http://tonigroshek.com/wp-content/uploads/2013/02/Like-Her.ogg

    Tip: You are also linking to the whole audio files which means a) it is a large file for users to download which will appear like the player is being very slow to load the track (and a lot of users just think it doesn';t work), and b) Visitors can pinch your music! So I personally always edit my sample tracks to just be a short clip. haha just to make your life harder...

  9. dcgroshek
    Member
    Posted 2 years ago #

    I'm back! : /

    I reloaded all my mp3/ogg files to my FTP and made sure there weren't any spaces in the file names. I'm at a loss as to what to do next.

    I can't even see the sample player on my page.
    Here are my page set-up shots:

    http://tonigroshek.com/wp-content/uploads/2013/03/player-as-right-side-bar-half-page-widget.png
    http://tonigroshek.com/wp-content/uploads/2013/03/listen-and-download-sidebar-info.png

    Thanks for your efforts on my behalf!

  10. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Hi dcgroshek... perhaps at this stage it might be quicker if you send me a private email with some temporary admin login details and I can jump in and take a look for you?

  11. dcgroshek
    Member
    Posted 2 years ago #

    Brilliant! Thanks for your offer to do so. Having visited your site, is this the email address I should use??

    info@enigmaweb.com.au

  12. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Yep that's the one

  13. dcgroshek
    Member
    Posted 2 years ago #

    OK......I think I sent it ?! I added you as a new user....hope I walked through that hoop correctly??

    http://tonigroshek.com/wp-content/uploads/2013/03/add-new-user.png

    Let me know what errors you find in my set-up. I have two other playlists I'd like to upload after fixing my errors with this first attempt.

    I REALLY appreciate your assistance in all this!
    Cheers : /

  14. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Hi again... have logged in and checked your site and the plugin is working completely fine, it's all in the configuration ;-p

    See http://tonigroshek.com/free-song-downloads/

    Have a bit of a look through the plugin settings to see how I've done this and I think you will see how it all works. In particular note the following:

    + I noticed you had 'button code 1' 'button code 2' etc instead of actual links that you want the buttons to link to. You also hadn't labeled the buttons in settings properly...

    + Your own playlists aren't working because the filepaths you've put in do not link to actual mp3 or ogg files... you need to upload your music files then take a note of the correct full URL and add those in the relevant fields...

    + Currently I've just put the demo player in as a standard shortcode in the page. I've used full width page template rather than trying to use the sidebar widget for the player... you could use the widget if you want - I checked it and it's working fine. But it's important to remember you can't have more than 1 instance of the player on a page/post... so you had shortcode in the page, then also because you were using a template with sidebar and sidebar widget it was breaking... make sense?

  15. bsoultrax
    Member
    Posted 2 years ago #

    Rebuilt my site and added just your plugging and 1 post. Before it only played the sample. Now it will play the 1st file of the playlist. Please advise. My url is:
    http://www.bsoultrax.com/wordpress

  16. dcgroshek
    Member
    Posted 2 years ago #

    Thanks "Maeve"! I can see from your test player settings what some of my errors have been.

    I think the only thing that's still causing me to scratch my curly head is this:
    + Your own playlists aren't working because the filepaths you've put in do not link to actual mp3 or ogg files... you need to upload your music files then take a note of the correct full URL and add those in the relevant fields...

    I have uploaded my mp3/ogg files to my WP media library and my GoDaddy FTP. I'm not understanding what other resource I'm supposed to be uploading them to so that said listener can then download from. I realize this falls into the "well, everybody knows the answer to THAT one!!!" category, so I appreciate your patience in advance. : /

    Cheers to you down unda.....

  17. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Just upload the file via Media Library, then over to the right you will see the URL... copy it, and paste it into the relevant field in the plugin.

    You can test that the file is working properly by going straight to that url in your browser... when I did this for your current filepaths I just got 404 errors... hence why the player isn't playing any files

  18. dcgroshek
    Member
    Posted 2 years ago #

    But I HAVE copied/pasted the full URL from the right side of the edit media page for each mp3/ogg.

    Let's take the song "Fill Me Up" as the example.

    I've pasted this URL http://tonigroshek.com/wp-content/uploads/2013/03/Fill-Me-Up.mp3

    into the appropriate fields on the "fill me up - edit song" page. Screen shot: http://tonigroshek.com/wp-content/uploads/2013/03/fill-me-up-update-song-page.png

    I've also pasted that URL into the button 1 link, which I hadn't done before.

  19. dcgroshek
    Member
    Posted 2 years ago #

    You can see from this screenshot that the URL lists the song in my FTP at the bottom of the screen here: http://tonigroshek.com/wp-content/uploads/2013/03/FTP-screen-shot.png

    I know you'd like to slap me in the face at this point! : /

  20. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    haha that's ok I'm happy to help...

    Ok so you need a working MP3 and you need a working OGG for each file.

    For that track when I check it now you are pointing to a working mp3... but the ogg version is still a 404 file not found... click this link and you can see for yourself

    http://tonigroshek.com/wp-content/uploads/2013/02/Fill-Me-Up.ogg

  21. dcgroshek
    Member
    Posted 2 years ago #

    Maeve, Maeve, Maeve......your level of patience astounds me!!!
    Thanks for keepin' at this with me : /

    Glad the Fill Me Up song track is working. The only configuration that I changed was pasting the Fill Me Up mp3 URL into the button 1 link on the "edit song" page. Perhaps I should paste the Fill Me Up ogg URL into the button 2 link???

    Lord, increase my patience and help me not to cry over this! Amen!!!

  22. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    haha that's ok - lots of practice at patience on these forums! ;-p

    Glad you've got it working.... BUT.... you really do need to paste in a working MP3 and a working OGG file in the correct fields for each track. Otherwise you are going to find it works on some browsers (like chrome, safari, explorer) but not on others (like Firefox which requires OGG). Sorry.

    Oh hey if you like the plugin and are happy with support it is very helpful if you can give a nice rating and review here. :-) Thanks!

  23. dcgroshek
    Member
    Posted 2 years ago #

    Here's a stupid question for you (!)

    Am I supposed to paste BOTH the mp3 and ogg URLs into ONE field, i.e. both URLs into the button 1 link?

    Drum roll please.......

  24. dcgroshek
    Member
    Posted 2 years ago #

    p.s. writing a glowing review about your support right now!

  25. dcgroshek
    Member
    Posted 2 years ago #

    MAEVE!!!!! i think i got it

    In addition to pasting both the mp3 and ogg URLs in the "button 1 link" field, I also added dashes in the song titles for the "song title" field. When you mentioned the dashes in previous posts, I assumed you were just referring to including dashes in the URL. It looks sort of silly to have dash marks in my song titles on the player, but WHATEVER WORKS!!! http://tonigroshek.com/free-song-downloads/

    THANKS FOR YOUR SUPPORT!

  26. Musicalman
    Member
    Posted 2 years ago #

    Your download buttons do not work!

    404 — Fancy meeting you here!

    Nice voice though :)

  27. dcgroshek
    Member
    Posted 2 years ago #

    @musicalman.....thanks for taking the time to let me know!

  28. dcgroshek
    Member
    Posted 2 years ago #

    @Maeve......I was able to figure out that I don't need dash marks in the song title field in order to get it to play correctly. However, now my download buttons lead to a 404 error.

    I have 3 different playlists on 3 different pages and made serious progress today with some of the other issues you've fixed for me : )

    http://tonigroshek.com/free-song-downloads/
    http://tonigroshek.com/weddings/
    http://tonigroshek.com/wedding-dinnerreception/

  29. Maeve Lander
    Member
    Plugin Author

    Posted 2 years ago #

    Awesome! Glad you got it working. :-) Andd thank you for your kind review - much appreciated.

    *Hey I think if you enable the ratings it will help your buttons align better ;-p

    ...marking this thread resolved now

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic