Support » Plugin: Library Viewer » Pro stopped working

  • Resolved perchera


    Hello Chris,

    I sent you an email, but just in case. I bought the pro version and it was working fine but since today i see this meassage in my website:

    You cannot use path parameter in shortcode.
    If you want to display the containing files and the containing folders of a different folder (instead of library) of your (FTP) server to your users in the front-end,
    consider buying Library Viewer Pro

    Any idea what happened? i have automatic updates for your plugin, apparently running 2.0.1 now

    Please, reply asap, it’s an essential part of my website

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Pexle Chris


    Hi, sorry for this.

    But Library Viewer 2.0.1 is a Major update and you need to update Library Viewer Pro, in order to work both.
    You can find the notice to update Library Viewer Pro in the top of your Plugins’ Page in your dashboard.

    Because Library Viewer Pro cannot offer at the moment automatic updates, please disable also the automatic updates of Library Viewer.

    Because Library Viewer Pro need specific version of Library Viewer in order to work.

    Have a nice day

    Thread Starter perchera


    Thank you Chris, i did not see that notice at the top of the page, i never see them in fact, ha ha ha. Working again, Thank you!

    Thread Starter perchera


    Sorry to bother you again, but now i see that:

    “You cannot use shortcode [library-viewer] more than 1 times in the same page. You can do this with Library Viewer Pro”

    I have installed it using the

    I see that this zip contains a library-viewer-pro.php like the original zip

    The original zip had a line like this:

    define(‘LV_PRO_LICENSE’, ‘stringoflicense here’);

    But the 2.0.0 does not have that line

    So i have edited the php in the 2.0.0 zip and now i find i have two plugins:

    Library Viewer and Library Viewer Pro

    Still the same problem, even if i deactivate LV and keep LVPro only

    I don’t wanna mess up anymore, so please let me know how to proceed

    Thank you!

    Plugin Author Pexle Chris


    The plugin in order to works, need both Library Viewer and Library Viewer Pro activated.

    Library Viewer Pro Installer (version 0.0.0) is not functional. Is only to activate the license in your DB and inform to update the plugin to the latest version.

    So Library Viewer Pro has not the license in the code in order to work. Is not need it.

    Do you try to use the shortcode more than one times in the same page?
    This is not working in Library Viewer Pro yet, because of a bug. In the next update of Library Viewer Pro I will have fixed it!

    Thread Starter perchera


    Hi Pexle,

    I always used shortcode more than one time in the same page and it always worked…

    Please fix it
    Thank you

    Plugin Author Pexle Chris


    I will give you an example
    if you use in the same page a shortcode with parameter have_file_access=”logged_in” access and an other shortcode with have_file_access=”administrator”, the files will not opened properly (the file viewer doesn’t know which shortcode must “see”).

    So, If in the past worked without problems, by accident worked without problems.

    This is why I have added this message in the later versions.

    I hope that in April I will release an update fix.

    If you want to rollback Library Viewer Pro, send me an email

    Thank you for understanding

    Moderator Jan Dembowski


    Forum Moderator and Brute Squad

    Pro stopped working

    @pexlechris Don’t support customers in these forums again. You’re not allowed to, no one is.

    @perchera For pro or commercial product support please contact the developer directly on their site. This includes any pre-sales topics as well.

    As the developer is aware, commercial products are not supported in these forums. I am sure they will have no problem supporting you there.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Pro stopped working’ is closed to new replies.