Support » Plugin: WP Google Maps » Pro Map Not Appearing

  • Resolved Frecosse


    Hi Nick,

    I’ve been working on a WordPress site for a client, and we installed the WP Google Maps plug-in (version 5.04) during the build.

    While limited, this worked fine to block out content for the page where the map appeared.

    The client has since directly purchased the Add-on package (version 4.05), and once activated, the map stops appearing.

    I’ve tried deactivating both plug-ins, and switching them on again in order to see if that makes a difference (without the add-on plug-in activated, the free plug-in shows the map again).

    I’ve also tried creating a completely new map to test that there’s not bad data in the first map, but that makes no difference.

    Having looked through the support forum, could find nothing that directly related to the issue we’re encountering. However, I can tell you that when the Add-on plug-in is activated, the following error appears in inspect element:

    Uncaught TypeError: Object [object Object] has no method ‘dataTable’

    I checked the source, and the page is able to find and load both the jQuery dataTable script and stylesheet. Perhaps this provides you with a clue however.

    The site is also currently in maintenance mode, to hide it from potential visitors ahead of launch – though this should not affect the plug-in. But it does make it difficult for me to give you access to the site to see it in action for yourself.

    We need to go live with this site as soon as possible, so any help/pointers would be much appreciated.


    Graeme Attkins
    Frecosse Website Design

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WPGMaps


    Hi Graeme
    First of all, thank you for supporting me and my plugin!

    This is quite strange. Are you running on IIS? Is the site on a development server that I can access? Is there a link that I can look at and perhaps try debug it from there. I may need to request log in information at some point too (this can be mailed to nick @ wpgmaps . com)

    I have also just released an updated version of both the basic and pro plugins. Please update your basic and then download the Pro version here:
    Let’s hope that solves the issue 🙂

    Looking forward to your response.

    Kind regards

    Hi again Nick,

    Tried updating both parts of the plug-in but it’s made no difference – still getting error messages, and the map is not appearing.

    Have checked with client, and can give you temporary access to the site, which I’ll e-mail you shortly – thought it just best to keep this conversation live for the time being!



    Following providing access to the forthcoming blog which was not displaying maps correctly, Nick was instrumental in tracking down the issue causing this.

    It turns out that jQuery was being called twice in the page, once in the header (where I had placed it) and again in the footer (where it was being called by WordPress itself).

    Removing the call in the header did not resolve the issue, as this plug-in needs to load jQuery before the maps, so it had to be removed from the footer.

    To do this, you need to ‘enqueue’ the jQuery script in the header – you do this by adding <?php wp_enqueue_script(“jquery”); ?> directly before the <?php wp_head(); ?> call in the header template.

    You must then call jQuery directly after <?php wp_head(); ?> in the same template.

    To remove it from the footer, you add the code <?php wp_dequeue_script(“jquery”); ?> directly before the <?php wp_foot(); ?> call.

    I’ve edited a fair few WordPress blogs in my time, and this auto-loading of jQuery is something that I haven’t come across before, so I suspect it’s something they’ve added fairly recently.

    Hopefully this will help anyone else encountering this issue!



Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Pro Map Not Appearing’ is closed to new replies.