Support » Plugin: My Private Site » Private Site plugin always causes redirect

  • Hi All,

    I’ve been struggling with this one for weeks now so i though its time to make a move on the forum front.

    The background of my situation is I have created a WordPress server on a Windows Server installation using IIS in my school to create a Knowledgebase for IT Eyes Only.

    I have the Knowledgebase working fine but cant seem to get the Private Site plugin working. It does restrict the website and request a login when you navigate to it but putting in any username and password just causes it to loop back to the login page every time you try and log in.

    Has anybody come across this before or know how to resolve it?

    I am using the Jonradio Private Site plugin alongside Active Directory Integration and WP Knowledgebase. I dont believe any of these plugins to be a problem as i have disabled them and the problem has still re-occured.

    Thanks

    https://wordpress.org/plugins/jonradio-private-site/

Viewing 4 replies - 1 through 4 (of 4 total)
  • The plugin has been adopted by David, as I was no longer able to provide Support, so David should be able to provide more help, but a couple of quick comments might help get you going in a hurry. Or at least help David analyze your problem.

    In theory, Page Caching could create the problem you describe. Check if any of your other plugins Cache. I was surprised to find how many plugins built for other things also provide Page Caching. If you are unsure, simply disable all your plugins except My Private Site and see if the problem still exists.

    There is also a very small chance that you have a Redirect Loop issue, though I’ve never seen one act this way. Check out the first item in the FAQ: https://wordpress.org/plugins/jonradio-private-site/faq/

    Mainly for David’s benefit, please list the setting you’ve chosen in the My Private Site plugin, especially the non-default settings.

    And, of course, confirm that you are using the current version of the plugin: 2.14

    Finally, I will be the first one to admit that testing in IIS environments has been minimal.

    Hi Jonradio,

    Thanks for getting back to me.

    I have tried disabling all plugins but your Private Site plugin and experienced the same problem so I dont think thats the issue.

    I had a look at your FAQ regarding redirect and selected the option to omit the redirect URL – “Omit ?redirect_to= from URL”
    This actually did something for me, instead of redirecting it opened up the Dashboard which normally it wouldn’t do although I am unable to open any pages within the site without it taking me back to the login and then going back to the dashboard after login.

    In terms of which settings I am using I have tried quite a few combinations and all setups do the same including the default settings.

    I am using the latest plugin.

    Thanks once again for your help.

    One last issue occurred to me after I wrote my previous post: your Browser. Browsers do a lot of Page Caching of their own, plus Browsers are the ones that store the Cookies that WordPress needs to know if you are logged in or not.

    The easy way to start is to use a different browser and see if the behaviour is the same. Then there is flushing the Page Cache, and checking the Cookie settings, especially refusing Cookies.

    Plugin Author David Gewirtz

    (@dgewirtz)

    You could also probably try incognito mode and do the same thing.

    –David

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Private Site plugin always causes redirect’ is closed to new replies.